Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an ACER Aspire 5332 laptop which I have just installed Ubuntu 12.04 x64, which is causing some issues with the video display on boot and video resolution.

First and foremost, it will only boot past the purple screen if GRUB has been edited to replace 'quick splash' with 'nomodeset'. Secondly, once it has booted with the the 'nomodeset' option, it does not allow me to change the resolution higher or lower from 1024 x 786.

Is it OK to use the 'nomodeset' for normal use? Will this compromise performance of other devices?

The video card is an on-board one, integrated within the Intel GL40 chip-set. The display is a wide-screen LCD, and under Windows could operate under various resolutions. Ideally I would like it to operate on a resolution to fit the wide-screen display as it a bit stretched out at the moment, and less desktop space as I am used to.

I believe the optimal resolution is 1366 x 768. Below is some information from the terminal which may be useful.

    ricstr@Aspire-5332:~$ lspci | grep -i VGA
    00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09)

    ricstr@Aspire-5332:~$ xrandr
    xrandr: Failed to get size of gamma for output default
    Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
    default connected 1024x768+0+0 0mm x 0mm
       1024x768        0.0*
share|improve this question
    
Not sure of the cause of your problem but when you set "nomodeset" the maximum resolution is 1024x768 and I believe that the graphics are lower quality. –  TrailRider Jun 18 '12 at 1:19
    
Thanks, I have tried to use a manual configuration of Xorg.conf for the 1366 x 786 resolution which did not work. I will try again without 'nomodeset' and report back. –  ricstr Jun 19 '12 at 1:32
    
Is there a solution? It seems that the Intel driver doesn't work with nomodeset as it needs Kernel Mode Setting. –  mparaz Dec 21 '12 at 10:31

1 Answer 1

I had the same problem with an Acer Aspire 4736z. Some searching led me to this solution:

Edit /etc/default/grub and and make this change:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor" GRUB_CMDLINE_LINUX="acpi_osi=Linux"

After that just run the command

sudo update grub

This worked for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.