Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know there is a similar post here: USB Bose speakers with ubuntu 12.04 But it hasn't been resolved/answered and I've learned a little more about the problem, so I thought I'd start a new thread on it.

I'm hoping someone can help me to get my Bose USB speakers to run through USB without crackling in Ubuntu 12.04 They are these speakers: http://www.bose.com/controller?url=/shop_online/digital_music_systems/computer_speakers/companion_5/index.jsp

Using the "sound" gui in 12.04, I have Output set to "Bose USB Audio." It often starts the subwoofer at maximum volume for some reason I don't understand.

The main problem is that playing video in Firefox or Chrome (both) eventually causes the sound to die (go completely silent). At other times, (like if I play an .avi file) the sound crackles or is garbled, but I can still make out the words people say fine.

It appears to be a pulse audio issue, but I've tried all the workarounds I've seen posted here, on ubuntuforums.org, and also on a few other sites, and nothing seems to work. I've make some followup posts but no one has responded. I can turn off my onboard sound in my system bios, but that doesn't seem to help. I've modified a .conf file, but that didn't work either (changing -2 to -1 to and deleting a couple lines so USB would load, but like I said, it's not that the sound won't work at all, it's that it seems to get overloaded and stop working).

Of particular interest, I have noticed that (a) the more tabs I open at once with video playing, the faster the sound goes silent and (b) I sometimes get sound when I move the mouse around the screen or when I scroll webpages.

Additionally, after working to solve this problem at some length, I seem to have introduced a new (though minor) issue: Now when I'm booting into ubuntu (when the splashscreen is on) I get some high pitched squealing sounds. They go away when my login comes up, but it would be nice to eventually get rid of this too.

Thank you for your help.

I posted a log file from my audio from during the problem (from working to non-working state) in the first link I copied above.

share|improve this question

1 Answer 1

This happens with Fedora F17 as well, and Debian and all the distributions I have tried. When pulseaudio is disabled (ALSA-only), then there are no problems with audio.

Pulseaudio is the problem. I have also observed it is related somehow to AUDIO VOLUME as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.