Did a ppa-purge of lucid-bleed and dpkg didn't downgrade properly and now it is broken.
dpkg: PreDepends: tar (>= 1.23) but 1.22-2ubuntu1 is to be installed
What scares me is when simulating the removal of dpkg I get:
Removing this package may render the system unusable. Are you sure you want to do that?
and then the list of packages which depend on it, which will also be removed, is obviously very long.
Is it safe for me to remove dpkg just to reinstall it? How would I ensure the list of packages which were also removed are then reinstalled?
Will forcing the version of dpkg help? (FYI: simulating a forced version brings up a much smaller list of applications which will also be removed).
Any other suggestions?
Additional information based on comments:
ppa-purge log: http://pastebin.com/1kT8cLvP
sudo apt-get install dpkg=22.214.171.124ubuntu4.5 I get
The following packages have unmet dependencies: libdpkg-perl: Depends: dpkg (>= 1.15.8) but 126.96.36.199ubuntu4.5 is to be installed
which sucks because that means more would be broken after doing so...but when I force the version through Synaptic I get: To be removed alien, build-essential, cdbs, checkinstall, debhelper, devscripts, dpkg-dev, google-earth-stable, googleearth-package, libdpkg-perl, lintian, lsb, lsb-core, lsb-cxx, lsb-desktop, lsb-graphics, lsb-languages, lsb-multimedia, lsb-printing, lsb-qt4, lsb-security, ubuntu-dev-tools.