Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use Ubuntu 12.04 with Polish localization. If I start: "quickly design", Glade shows up with Polish interface. I don't like that, I'd like Glade to be in English. How can I achieve that?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

You can start Glade in English by giving

env LANG="en_US.UTF-8" quickly design

or

LC_ALL=C quickly design

or

export LANG="en_US.UTF-8"; quickly design

commands in terminal. If you want to set permanently Glade's language to English, you can edit the launcher of Glade with the help of this. You have to change 'Exec' line like this:

Exec=env LC_ALL=C quickly design

I hope this will help you.

share|improve this answer
    
Thanks. Although the first command gives me an error message, the rest are fine. –  mivoligo Jun 18 '12 at 8:23

This is actually simple. Instead of

quickly design

run:

LANG=en quickly design.

This trick works for almost every application, since they all determine your language settings on the basis of LANG (sometimes LANGUAGE or LC_MESSAGES are also significant).

share|improve this answer
    
Thanks. Nice and simple. :) –  mivoligo Jun 18 '12 at 8:23
    
I believe for the LANG environment variable you'll have to specify a fully qualified locale name (e.g. en_US.UTF-8). If you want to simply specify en, you should be using the LANGUAGE variable –  David Planella Jun 18 '12 at 11:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.