Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Unity & Gnome 3.4 installed successfully. All Dell keyboard keys work perfectly with both. I installed kde - full via terminal. Everything is working great except for the hotkeys. No calculator, no Mute, nothing. I check which keyboard is selected and choose Dell Multimedia USB Keyboard. No luck.

How do I get my Dell keyboard to work with kde - the same keyboard that works with Unity & Gnome 3.4.

Thanks in advance for any advice.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

There are different menus for changing keyboard shortcut settings in KDE. You can find them by searching for "shortcut" in the Kickoff menu.

"shortcut" search in Kickoff menu

For example, to change the hotkey for the Mute action, you go to Global Keyboard Shortcuts and select KMix (which responds for sound).

Global Keyboard Shortcuts – KDE Control Module

To add your own shortcuts, you can go to Custom Shortcuts. Let's make a shortcut for KCalc – KDE's default calculator. Right-click on the box to the left, select NewGlobal ShortcutCommand/URL. Give your new shortcut some name, go to Trigger tab, pick a key, then go to Action tab and write kcalc there. You can launch different applications, open web pages or perform other command line actions, that depends on what you write here.

Custom Shortcuts – KDE Control Module

Also note that there are per-application shortcut settings in each application's SettingsConfigure Shortcuts... menu.

share|improve this answer
    
Thanks for the tips, I will give it a try later when I have more time. I find it a bit odd that a Dell Multimedia USB keyboard isn't configured. I can see how many people would not want to be bothered with KDE for that reason. I do like it as it appears to be fast and a nice change from Unity and Gnome 3.4. –  chazdg Jun 18 '12 at 14:16
    
@chazdg Going through all the System Settings can be very rewarding. –  Oleh Prypin Jun 18 '12 at 14:44
    
@chazdg And instead of thanks this site has upvotes. –  Oleh Prypin Jun 18 '12 at 14:55
    
I got you covered. Well,I got the Mute Button working. I have tried every configuration for a basic calculator, but it simply will not work. I tried everything from your example to going with System Settings. I can get any calculator I want by right clicking the desktop and typing it in. Then, I tried to assign it the correct key, but it still won't work. The other key I can't find is the Launch key. I'm not sure how rewarding it is to go over the entire thing, entry by enty. Any help you can give is appreciated. –  chazdg Jun 18 '12 at 18:58
    
@chazdg You probably haven't installed KDE's calculator. Try gcalctool or whatever the GNOME's calculator is called instead of kcalc. Not sure what you mean by "launch key" though. There is no good way to assign a shortcut to Super key. Try Alt+F2 (this can be changed under Global Keyboard ShortcutsRun Command Interface) or Alt+F1. P.S. I said looking through all the settings is rewarding because you will find many, many ways to make the system better for yourself, not just hotkeys. –  Oleh Prypin Jun 18 '12 at 19:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.