Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use docky in Gnome-Shell and it's annoying that when I minimise a window, it goes up to the top left corner. I know mutter isn't that customisable but is it possible to get a minimise effect similar to that of Cinnamon, here the window just shrinks and disappears? Thanks

share|improve this question
up vote 3 down vote accepted

You can't simply change the animations. I had a time when I wanted to do that. If you want to change the animations for gnome-shell. You'll have to change the code for the window manager itself. I know it sucks.

share|improve this answer

example> sudo vi /usr/share/gnome-shell/js/ui/windowManager.js

find method

      _minimizeWindow : function(shellwm, actor) { ...

and.. you can see that

            xDest = monitor.x;
            yDest = monitor.y;

            if (Clutter.get_default_text_direction() == Clutter.TextDirection.RTL)
                xDest += monitor.width;
            xScale = 0;
            yScale = 0;

change like this!

            xDest = window.x;
            yDest = window.y;

            xScale = 1;
            yScale = 0;

roll up window animation ^^

:: Warning! ::

If your syntax is wrong, you may break your GUI completely. In that case, you have to use Alt+Ctrl+F1 and rollback.

share|improve this answer
You failed to mention when changes take effect. Reboot or logout, then login? – Muriuki David Jul 5 '15 at 15:41

You need to modify file /usr/share/gnome-shell/js/ui/windowManager.js The function you're looking for is WindowManager's _minimizeWindow. Changing xDest and yDest properly will meet your requirement, hopefully.

share|improve this answer

You've tried installing compiz? And CCSM? (compiz-configuration-settings-manager)

As in the comments to my answer, compiz isn't compatible with mutter. So this is NOT the right answer. Not deleting, though, so anyone else like me visiting knows this isn't the answer.

share|improve this answer
I did before and it made the panel go away and I couldn't really do anything. – John Jun 17 '12 at 20:32
I suggest going down that path more... did you try right click on desktop and add a panel? – Chris K Jun 17 '12 at 20:34
Compiz and CCSM will not work in gnome-shell. since gnome-shell's window manager mutter has conflict with compiz – Anwar Shah Jun 17 '12 at 20:34
ah, there we go :P – Chris K Jun 17 '12 at 20:36
I think you may be confused. I'm not using Gnome Classic, I'm using Gnome 3 Shell and from what I heard, Mutter is very closely integrated with the Shell and can't be replaced by Compiz – John Jun 17 '12 at 20:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.