Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Ubuntu 12.04. Network controller is BCM4311, lap top is a Dell Latitude D830. I've updated, upgraded, installed firmware-b43-installer, fwcutter, and it's still not detecting my wireless internet. iwconfig says no wireless extensions for lo or etho even though the controller is detected. Trying to manually add the wireless network through network manager also hasn't worked. It's just not detecting the wireless network.

Showing the driver is apparently working

And the output from lshw -c network:

*-network UNCLAIMED     
   description: Network controller
   product: BCM4311 802.11b/g WLAN
   vendor: Broadcom Corporation
   physical id: 0
   bus info: pci@0000:0c:00.0
   version: 01
   width: 32 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list
   configuration: latency=0
   resources: memory:fe8fc000-fe8fffff

Output from rfkill list all:

0: dell-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
1: dell-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
2: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

What else can I try? All of the solutions I've seen have said that fwcutter and the firmware-b43-installer are the answer but they haven't been working for me.

share|improve this question
Did you reboot? unclaimed = no driver/module loaded. Please reboot and paste output of lsmod. – izx Jun 18 '12 at 12:21
Yes, I rebooted. Here is the lsmod output: – Dale Jun 18 '12 at 13:34
lsmod output – Dale Jun 18 '12 at 13:42
lsmod output part 2 – Dale Jun 18 '12 at 13:45
It's still using the wl driver -- uninstall that please. (no b43 in list...) – izx Jun 18 '12 at 13:55

As can be seen at the comments, izx helped the OP to solve the problem, but he never posted an answer and he was last seen 10 months ago, so I'm posting this based on OP's comments.


sudo rmmod wl

to remove wl module and:

sudo modprobe b43

to load b43 module.

You can force b43 loading and prevent wl loading at boot by running:

echo "b43" | sudo tee -a /etc/modules
echo "blacklist wl" | sudo tee /etc/modprobe.d/blacklist-wl.conf
share|improve this answer
@Alaa Thanks. Fixed. – Eric Carvalho Jun 22 '13 at 19:04

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.