Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Maverick Meercat on an Acer Aspire 5100 with 2GB of RAM and an ATI Radeon Xpress 1100 graphics card.

I can't watch any video at all on this computer. I use both Firefox and Chrome and they both have the same problem. When I attempt to watch vimeo or youtube videos the playback is so choppy that it can't be watched. I have installed everything I can (I think so anyway, I am a beginner with all this linux).

Any idea's? When the computer was running XP it didn't have these issues...

share|improve this question
    
What flash player did you install? It is best to go with Adobe's official, because alternatives can be choppy or break unexpectedly. –  evgeny Nov 28 '10 at 5:47
    
Try running this in Terminal (Applications->Accessories->Terminal): sudo apt-get install flashplugin-nonfree and restart Firefox. –  evgeny Nov 28 '10 at 5:49
    
Hi, I have the new version that is automatically installed in chrome. –  Greg Nov 28 '10 at 5:51
    
Wow!! Evgeny!! Thanks :).. just did it and video from both vimeo and youtube plays properly!! So, looks like firefox will be the browser of choice as the problem exists in chrome still.. –  Greg Nov 28 '10 at 6:28
    
I will re-post my comment as an answer, please tick it as accepted. –  evgeny Nov 28 '10 at 8:01
add comment

3 Answers

Open Terminal, and execute the following command,

sudo apt-get install ubuntu-restricted-extras
share|improve this answer
    
Thanks Karthick, did this just before. :) –  Greg Nov 28 '10 at 6:28
    
Is that working?Now can you play videos? –  karthick87 Nov 28 '10 at 6:56
add comment

Try running this in Terminal (Applications->Accessories->Terminal): sudo apt-get install flashplugin-nonfree and restart Firefox.

To make it work in Chrome, sudo cp /usr/lib/flashplugin-installer/libflashplayer.so /opt/google/chrome/plugins/ and restart Chrome.

share|improve this answer
    
You don't need the symlink thing for chrome anymore –  Jorge Castro Nov 28 '10 at 15:59
add comment

With the chrome browser I had out of sync and choppy vimeo playback, and no playback at all with youtube. I found this advice somewhere - can't find where now - however....

I downloaded and installed this - chromium-codecs-ffmpeg-extra from the software centre and now all is working perfectly. When install is selected, a window pops up which says that "free fmpeg codecs .. must be uninstalled first". If you go for that it seems you have to uninstall chrome as well. I left both installed and chose the "install anyway" option and bingo!

I'll try and find where I stumbled across this solution and thank the contributor. It's been a godsend to a total clueless newbie to Ubuntu.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.