Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 11.10 (dual booted with Windows 7) but I'm unable to access Internet wireless even though I can do so on Windows 7.

The output for rfkill list all is given below:

rfkill list all 
0: brcmwl-0: Wireless LAN   
Soft blocked: no    
Hard blocked: yes
1: hp-wifi: Wireless LAN    
Soft blocked: no    
Hard blocked: no

The output for sudo lshw -C network *-network DISABLED is:

   description: Wireless interface
   product: BCM4313 802.11b/g/n Wireless LAN Controller
   vendor: Broadcom Corporation
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: eth1
   version: 01
   serial: 11:11:11:11:11:11
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=wl0 driverversion=5.100.82.38 latency=0 multicast=yes wireless=IEEE 802.11
   resources: irq:16 memory:c2500000-c2503fff   *-network
   description: Ethernet interface
   product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:03:00.0
   logical name: eth0
   version: 05
   serial: 22:22:22:22:22:22
   size: 100Mbit/s
   capacity: 100Mbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl_nic/rtl8105e-1.fw latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
   resources: irq:42 ioport:3000(size=256) memory:c0404000-c0404fff memory:c0400000-c0403fff
  • Broadcom STA wireless driver is installed, activated, and currently
    in use.
  • My laptop is a HP-Pavilion-g6-1004tx.
  • My hardware switch is on.

  • Enable Wireless option is also disabled in network settings.

share|improve this question
    
Do u have any hardware switch for switching on your wireless. I think you should check that first. –  Vinit Jun 17 '12 at 16:03
    
I have enabled it. Still Wireless Network option is disable. –  silenTK Jun 17 '12 at 16:09

7 Answers 7

If you can't repair your wlan interface, wifi network, you must do this:

First activate your wifi by shortkey of your computer (for example Fn+F2).

Then:

rfkill unblock all
sudo /etc/init.d/networking restart
sudo rm /etc/udev/rules.d/70-persistent-net.rules
sudo reboot

Now I have wlan up.

share|improve this answer
    
What is Fn key on a PC Keyboard? I have seen those on laptops only –  RAbraham Oct 26 '13 at 23:01
    
Should be sudo rm /etc/.. not sudo rm /et/... –  Cort3z Jun 18 at 12:34

Try restarting your computer,

Enter bios

Set settings to default

Save Settings

Restart.

Works for me

share|improve this answer
    
I'm experiencing this problem since 2 weeks after update. –  silenTK Jun 17 '12 at 16:12
    
Does it work? It's driving me crazy too, I don't know whether it's my hardware or a bug. –  Joshua Siret Jun 17 '12 at 16:13
    
No it doesn't work. Because it's working fine in windows7.but not in ubuntu 12.04 after updating it. –  silenTK Jun 30 '12 at 13:51
    
Funny enough, this is just all I needed to have done to get mine working. Thanks. I wish I can vote up more than once so that this stands out. –  Peter Oct 31 at 14:13

A useful forum post points to the following actions as a solution.

First, run the following commands.

sudo modprobe hp-wmi
rfkill unblock all

Now, check if your card is still blocked.

rfkill list all

If it still doesn't work, hit Function F12 and see if 'hard blocked' changes to no. Also, try Alt F12.


If this still doesn't work, you can try using the open-source drivers instead of the proprietary ones. As mentioned here, the proprietary "driver is more likely to cause problems than to resolve them. Most of the problems reported by users on Broadcom chips are caused by this driver. Using this is HIGHLY NOT recommended. Before you even think of trying out this one, make sure to try the other drivers first."

So, let's do that.

echo 'blacklist mac80211
blacklist brcm80211
blacklist cfg80211
blacklist wl
blacklist lib80211_crypt_tkip
blacklist lib80211' | sudo tee -a /etc/modprobe.d/blacklist.conf

sudo sed -i '/exit 0/i \
modprobe brcm80211' /etc/rc.local

This will load the open-source driver module at the end of each boot process.

Kudos to jokerdino for this one.

share|improve this answer

Download the drivers from this link http://downloads.openwrt.org/sources/broadcom-wl-4.150.10.5.tar.bz2.

Now to need to extract the file.For that you need to go to directory where the file is downloaded. Open your terminal and type cd /home/username/Downloads and then type tar -xjf broadcom-wl-4.150.10.5.tar.bz2.When you type this command what it does is that all the content of the tarball gets extracted in the same directory the tarball is. Now get into Superuser shell because you will be needing full rights.For this you can type su — and followed by root passwd if you are using fedora and alikes. If using Ubuntu/mint/ type sudo -s and then followed by passwd. You will get into root shell and will get # instead of $. Now you need to change the directory to the extracted drivers. For this type cd /home/username/Downloads/broadcom-wl-4.150.10.5/driver/ Finally you need to extract all the drivers to the relevant directory.For this type : #b43-fwcutter -w /lib/firmware wl_apsta_mimo.o Now restart your system and guess what you can use your wifi without any hitch.

share|improve this answer

Try this. There's a chance that it will work, but I can't tell for sure.

Please make sure the backports repository is enabled.

Then, install the package linux-backports-modules-cw-3.1-oneiric-generic (supposing you are running a generic kernel. You can find out by running the command uname -r).

share|improve this answer

Simply typing rfkill unblock all, should work.

And restart the computer.

share|improve this answer

I just simply did Fn+F12 and it automatically started up a connection to my network.

share|improve this answer

protected by Community Oct 8 '13 at 17:01

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.