Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've seen this issue on previous versions of Ubuntu, but not on 12.04 and some of those are resolved bugs, so I'm asking again.

I've set up power management so that, when plugged in, my laptop does nothing when the lid is closed. I do this so that I can use as a desktop with my external monitor with the screen closed and the laptop scurried away from my desktop.

I tried turning off the laptop monitor to see if that made a difference, but it doesn't.

The problem is that closing the lid still shuts off my external monitor. What can I do to prevent this?

share|improve this question
1  
Possible duplicate? askubuntu.com/questions/15520 –  fossfreedom Jun 17 '12 at 20:54
1  
The few things on that page that applied to 12.04 seemed to make no difference. –  Thom Jun 17 '12 at 21:47
    
You might want to look at askubuntu.com/questions/145342/… and askubuntu.com/questions/161649/… if you haven't already. There are some ideas in there, but unfortunately no one seems to have a solution. –  Tomas Aug 2 '12 at 7:28
add comment

3 Answers

The only way I managed this: hit dash and search for displays.

enter image description here

2 things I noticed:

  • the 'off' does not get saved;
  • I still need to keep the screen physically up. Closing the lid kills the 2nd monitor too. If you do close the lid and put it back up both screens light up.

The problem is that closing the lid still shuts off my external monitor. What to do?

Found it: after the 2nd monitor turns off move the mouse or type something. The 2nd monitor will turn on.

share|improve this answer
    
The problem with this solution is that you have to do it every time you restart your computer.. There has to be a way to make a script or something that will do it automatically. Plus, I couldn't turn off my laptop monitor until i selected "Mirror displays" and then unchecked it again. Before doing that, the on/off button was disabled. –  Knownasilya Jan 1 '13 at 21:47
    
Nope. It works for me even after a reboot @Knownasilya and I also have never had problems with the toggle being disabled. –  Rinzwind Jan 1 '13 at 21:56
1  
Maybe it's because I'm using 12.10 with Gnome 3? –  Knownasilya Jan 1 '13 at 23:35
add comment

Managed to do this by installing dconf tools and disabling org->gnome->desktop->screensaver: * idle-activation-enabled

I also had to set the 'Turn screen off when inactive for:' setting to 'Never' on the 'Brightness and Lock' section of the Ubuntu settings.

Lastly, I had to make sure that displays are not mirrored (Check box on 'Displays' settings dialog)

Now it finally works.

share|improve this answer
add comment

I scoured the 'net for solutions that respected the Ubuntu/GNOME settings but ultimately this was the only thing that worked for me:

sudo vim /etc/UPower/UPower.conf

# <snip> ...

ignoreLid=true

# <snip> ...

It required a reboot to take effect.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.