Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed 12.04 on a Fujitsu Siemens Amilo Pro. Wifi card does not work. Have tried various threads but none have the same problem. Think I have the correct firmware but the following comes up:

gill@ubuntu:~$ iwconfig
lo        no wireless extensions.

eth1      IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Channel:0  Access Point: Not-Associated   
          Bit Rate:0 kb/s   Tx-Power=off   Sensitivity=8/0  
          Retry limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth0      no wireless extensions.

Also:

gill@ubuntu:~$ rfkill list all
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

There is a power switch for wifi but it does not do anything in Ubuntu.

share|improve this question
    
I have exactly the same problem. Have you found any solutions since then? –  Christoph Jul 21 '12 at 8:20
    
I have the same problem, but would like to provide more info to hopefully solve it. Should I open a separate question (although it could be regarded a duplicate)? –  Christoph Jul 21 '12 at 9:07
    
Please look at this post askubuntu.com/q/107169/37991 for something to try. –  Sri Jul 30 '12 at 18:41
add comment

2 Answers

Did you try rfkill unblock all ?

share|improve this answer
    
afaik this can only remove soft-blocks, but his chip is hard-blocked. –  Christoph Jul 21 '12 at 8:19
1  
On my Dell this unblocks the hard-block too. The Wifi indicator turns on like when I press Fn + F8. –  To Do Jul 25 '12 at 17:01
    
This is really a comment, not an answer to the question. Please use "add comment" to leave feedback for the author. –  Mitch Aug 20 '12 at 6:44
    
@Mitch This is in question form, but it's an answer--it's intended as a solution to the problem (and might work). –  Eliah Kagan Aug 22 '12 at 8:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.