Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to connect an Zotac Nvidia Ion motherboard to my new Pioneer A/V through HDMI on a Ubuntu machine.

While I was fiddling around with the nvidia-settings I managed to make the system work:

  1. I went to DFP-1 (Pioneer...) in nvidia-settings
  2. Unchecked "force full gpu scaling" in "Flat Panel Scaling"
  3. Switched the hdmi cable over to the A/V
  4. Presto! I had sound and video

The problem is that if I restart, I lose the image again. And if I switch back to the LCD, I see the "force full gpu scaling" is again checked.

How can I make this permanent? I tried adding FlatPanelProperties" "DFP-1: Scaling = Native;", but I must be missing something: when I restart that setting is not applied and nvidia-settings has the checkbox checked. I attach my current xorg.conf file. I appreciate all the help with this!

My xorg.conf file (the relevant bit):

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Pioneer Electronic Corporation VSX-S300"
    HorizSync       31.0 - 84.0
    VertRefresh     57.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "ION"
#    Option "CustomEDID" "DFP-1:/etc/X11/pioneer.edid"
    Option "FlatPanelProperties" "DFP-1: Scaling = Native;"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
#    Option         "TwinView" "0"
#    Option         "metamodes" "1920x1080_24 +0+0; nvidia-auto-select +0+0; 1920x1080_60 +0+0; 1280x720 +0+0"
#    SubSection     "Display"
#        Depth       24
#    EndSubSection
EndSection
share|improve this question

1 Answer 1

up vote 0 down vote accepted

I had a simmaler problem with nvidia settings last time I used it I clicked nvidia config at the bottom of the pages list and save current config in the bottom right of that page now it always boots with my settings hope this helps

ps Also you must run nvidia setting as root

open terminal

type SUDO NVIDIA-SETTINGS

press enter

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.