Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday, I have updated my Ubuntu 12.04 installation. After a restart, Ubuntu chose Chinese or some similar as default language. So, all my menus/windows are a mix of English and Chinese. Previously, I had the German language active.

I was able to re-order the language within the language-support. German is now my first option, followed by English and - maybe - Chinese. But now, my system is a mix of English (for the activity screen and the most programs like Firefox) and Germen (only for some the left panel of the gnome-tweak-tool).

In All Settings >> User Accounts I have selected German for the language.

It seems, that Ubuntu ignores all my language settings - it's still in English. I have also tried, to re-install the language packs, but with no success.

Any suggestions, to bring my desktop back to the German language?

share|improve this question
    
Did you apply German System Wide? –  Mitch Jun 17 '12 at 16:54
    
I would like to see the content of the following files: ~/.profile, /etc/default/locale, /etc/environment, ~/.dmrc. –  enzotib Sep 1 '12 at 10:57

1 Answer 1

I had the same problem and I tried this:

  1. Go to "System Settings" --> "Keyboard **Layout"
    (in German it is "Systemeinstellungen" --> "Tasten"

  2. Add the "English" keyboard layout to the list. Now there will appear a keyboard-symbol in the menu-bar beneath your name, etc.

  3. Click at that symbol and select "German".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.