Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

last week I switched from Ubuntu 10.10 to 12.04 and after setting up my keyboard shortcuts, e.g., CTRL+ALT+E for my favorite editor and CTRL+ALT+X for the terminal, I noticed that the behavior when pressing the appropriate keys changed somehow.

I know this is very subjective and I am not 100% percent sure if I am suddenly just too lazy when using my keyboard, but here is what I noticed:

To run your shortcuts, you usually press the modifiers first and in addition press the alphanum key. Now, if I hold the modifiers down very consciously and press the alphanum key afterwards everything works fine. However, I noticed that I may often release the modifiers a bit too early. In Ubuntu 10.10 (metacity/compiz) my keyboard shortcuts would still execute and my tools would pop up. This does not work anymore in 12.04. Nevertheless, I still believe the old behavior to be more intuitive and would like to have it back.

I a nutshell: Is there a parameter to control the shortcut-key-press detection behavior?

I already searched the ubuntu keyboard options and searched for "keyboard" in gconf-editor but could not find any hints so far.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Yes there is in the compiz settings. To install it :

sudo apt-get install compizconfig-settings-manager

Compiz is a compositing manager, which means that it enhances the overall user interaction by adding fancy effects to your windows, from drop shadows to awesome desktop effects like the Desktop Cube or the Expo view. Compiz can also be a window manager, which means that it is the software between you and your desktop apps. It enables you to move or resize windows, to switch workspaces, to switch windows easily (using alt-tab or so), and so on. You can install Compiz Setting Manager on Ubuntu 12.04 Precise Pangolin/Ubuntu 11.10 Oneiric Ocelot/Ubuntu 11.04 Natty Narwhal/Linux Mint.

There in the respective setting you will be able to edit the shortcut keys.

share|improve this answer
    
I already have it, but thx for the hint. I thought the compiz settings would not work for unity2D (using 2D because it is more compatible with my fullscreen wine games). I could delete my shortcuts in the ubuntu settings and move them to the compiz settings. Very good! The compiz detection works much more intuitive, now I can again use my lazy shortcuts. Answer accepted! –  Juve Jun 17 '12 at 9:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.