Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
How do I modify or disable the HUD's use of the Alt key?

When I press ALT key on virtualbox machine (ex XP), ubuntu 12.04 catch that key.

How to prevent ubuntu catch ALT key?

Thank you~

share|improve this question

marked as duplicate by jokerdino, Tom Brossman, Ringtail, Jorge Castro, Anwar Shah Sep 12 '12 at 2:10

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
I think your only choices are for the guest to capture all special keys, or no special keys. Do you want the key passed on to the host machine, or do you simply want Ubuntu to ignore it? – Marty Fried Jun 17 '12 at 3:37
    
I want ubuntu to Ignore. – sam Jun 17 '12 at 3:54
up vote 14 down vote accepted

Disabling the Alt key from showing the HUD:

  • Install CCSM with sudo apt-get install compizconfig-settings-manager

    enter image description here

  • Start it from the Dash or by typing ccsm from the terminal.

  • Type "Unity" in the filter box on the left, and click on the Ubuntu Unity Plugin:

    enter image description here

  • Click on the <Alt> button the red arrow points to, and then uncheck the Enabled box. Click OK and close CCSM -- the Alt shortcut is now disabled.

  • If you no longer need CCSM, please consider uninstalling it.

    enter image description here

share|improve this answer
1  
Why are your recommending uninstalling CCSM? – Tom Thorogood Jun 17 '12 at 15:04
    
Because it seems newbies often want to play with it once they try it out, and the next thing you know, it crashes, all they have is a blank desktop and they panic :) – izx Jun 17 '12 at 15:08
    
Ha. Gotcha. But that's how they learn, right? /grin – Tom Thorogood Jun 17 '12 at 15:10
2  
Is there a way to make Hud only capture the right Alt key, not the left Alt? – becko Mar 20 '15 at 16:36
1  
To capture only the right Alt key, click "Grab key combination", press the right Alt key (it should show "Multi_key"), then close the "Please press the new key" dialog box. – SmileyChris Jan 24 at 20:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.