Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I saw a desktop manager named "Awesome" earlier on Google+, and thought I'd give it a try. In short, I didn't like it, but it got me wondering what other desktops were like, which I hadn't tried. The first one to come to mind was LXDE. I installed that, and tried it. I wasn't a big fan, so I just went to log back into KDE. Only, when I log in, everything is screwy. My theme is weird (although, according to system settings, it is still the same). All the categories and application short cuts in the KMenu are gone, except my favorites, which are now renamed with the "short name", it seems. I know these things are global resources, so it is very likely that one of these Window Managers screwed it up, but I need it fixed.

Actually, it seems that after restarting the theme problem fixed itself, but the KMenu items disappearing is still a problem. Does anyone know where these items are stored? (I know they are are just .desktop files somewhere, IIRC, but I don't remember where they are usually stored so I can see if they are still there). I'm hoping it's just a matter of a broken link or something somewhere, not deleted shortcuts... :/

In summary: Any ideas on what caused this? Do you know how to fix the KMenu, or at least where the .desktop shortcuts are stored for the KMenu so I can see if they still exist (crosses fingers).

share|improve this question
It looks as if I found the .desktop items in /usr/share/applications and /usr/share/applications/kde4, but I don't know how they got disconnected from KDE... – Caleb1994 Jun 17 '12 at 2:03
Try sudo apt-get remove menu-xdg – Tachyons Jun 17 '12 at 3:21
Before seeing your comment, I actually removed both WMs and did a apt-get autoremove. My favorites items are still renamed, but that is simple to fix. All my application categories are back and keyboard shortcuts work again. It says menu-xdg isn't installed, and that's probably why. I can't say your solution was technically right, but after removing it (among other things), everything is back to normal. – Caleb1994 Jun 17 '12 at 19:09
I should have removed the WMs the minute this happened. It would have saved some time... I knew this stuff was global resources, though, so I thought the WM had just messed it all up, and it didn't matter whether I uninstalled it or not. – Caleb1994 Jun 17 '12 at 19:10
@Caleb1994: Did you resolve your issue? – pl1nk Jun 24 '12 at 13:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.