Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've installed the fluxgui package from Killian Valkhof's PPA ( and started the applet by pressing alt+f2 and typing in fluxgui.

The inidcator icon shows up and I've entered my latitude/longitude, but my screen colors aren't changing. The applet fails to open its preferences dialogue as well.

What gives? Any solutions?

share|improve this question
f.lux is now available for Ubuntu through Launchpad PPA. You can install this using Terminal. Execute the following commands one-by-one to install f.lux on Ubuntu. sudo add-apt-repository ppa:kilian/f.lux sudo apt-get update sudo apt-get install fluxgui After installation it'll appear in Ubuntu indicator. Click the f.lux icon from the app indicator menu and click on Preferences. Now give your latitude and longitude. If you don't know yours, that's okay. You'll find an option beneath to find your latitude and longitude. It'll direct to a web address. Name your area in the search bar. Select t – ZachM1 Jan 23 '13 at 6:36
so is there anyone who have done it? – user142644 Mar 22 '13 at 21:33
This actually installs and launches fine, but it does not change temperature at all on Ubuntu 12.10. – Yuan Mar 30 '13 at 10:25
I got f.lux running but the preference panel won't open. So not sure if it's actually doing something. – Voles Oct 22 '13 at 14:51
@Voles, I think you're having the same problem as the rest of us. The good news is that F.lux just pushed an update (the first in a number of years), so these issues may soon get fixed... maybe. – blz Oct 23 '13 at 10:47
up vote 31 down vote accepted

Having the same problems with f.lux and there doesn't seem to be any fix for this right now.

But Redshift seems to work fine on Ubuntu 12.04.

gtk-redshift in Ubuntu Software Centre

share|improve this answer

I got f.lux working by downloading the xflux daemon available from I cannot get the GUI panel to open but can configure xflux via the command line and the f.lux icon says it is active.

share|improve this answer

protected by Community Mar 22 '13 at 21:34

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.