Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday I upgraded my version of Ubuntu. In stead of Gnome I now have the Unity environment. I'm not sure I like Unity better, so I'll give it a probation period to see if it's any good.

What I really do not like though, is the Global menu bar. After googling I found that I had to enter:

sudo apt-get remove appmenu-gtk3 appmenu-gtk appmenu-qt

If I do that I get the error message:

E: Unable to locate package appmenu-gtk3

Can anyone tell me what I'm doing wrong here and explain how to fix this problem?

share|improve this question

3 Answers 3

It already means that you don't have the appmenu-gtk3 package installed in your computer.

If you are not convinced, try removing something that you obviously know doesn't exist.

For example,

sudo apt-get remove kinglear 

would give the following error message:

E: Unable to locate package kinglear

share|improve this answer
    
Okay thanks, but it should be installed, or otherwise I should not have that global status bar. And if I want to install it, it still cannot find that package. (If I do apt-get install appmenu-gtk3 I get the same error message) So now my question is twofold: How do I uninstall the global menu bar, so that each window get's it's own menu. The other is: if ubuntu cannot find a package to install or uninstall how do I let it know where to find it? –  dre Jun 17 '12 at 6:52

To remove the menu bar,

Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below.

sudo apt-get autoremove appmenu-gtk appmenu-gtk3 appmenu-qt

Also you could try removing it by using Synaptic Package Manager. If you need to install it

share|improve this answer
    
thanks for answering, but the problem is that if I enter that line in a shell I get an error message: "E: Unable to locate package appmenu-gtk3", so what am I doing wrong? –  dre Jun 16 '12 at 20:20
    
@Mitch: the link from the logo does not "appear" in any browser (i.e. not clickable). Please fix when you get a chance... –  izx Jun 18 '12 at 14:00

Yes, if it says there is no package as appmenu-gtk3, it is indeed the case. But you can disable global menu by following below procedure:

Go to /etc/X11/Xsession.d/ and open the files 80appmenu-gtk3 and 80-appmenu with administrative power.

command in terminal: sudo gedit /etc/X11/Xsession.d/80appmenu-gtk3 and comment out all the lines by putting a # mark before each line.

do this also for 80appmenu, by opening with sudo gedit /etc/X11/Xsession.d/80appmenu.

Logout and login again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.