Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Toshiba Satellite Laptop Model P745-S4102 with Intel integrated graphics and Ubuntu 12.04 LTS installed recently. When I connect my HDMI TV to it I only get video through it and no audio. In the System Settings -> Sound, there is no option to select HDMI as the output. I read other threads in this site and it seems like at least guys had HDMI option but no sound. I don't even get that.

Please help!!

share|improve this question
    
Sometimes I have to reboot for it to show up. Have you tried that yet? –  Nathan Dyer Jun 16 '12 at 20:12
    
@Nathan Dyer I tried rebooting but didn't help. –  Santosh Jun 17 '12 at 14:10
    
Stuart's instructions about installing the proprietary graphics driver also helped me while using Ubuntu 13.10 through an HDMI TV port. This is the simplest Ubuntu HDMI sound solution across the web--very little installation is required! –  user230610 Jan 1 at 6:46
add comment

4 Answers 4

My GF got ASUS X55A and had same problem. Just Video, no Audio from HDMI port. I solved it in two steps:

First step:

uninstall driver in "add/remove programs" software for audio drivers called "Via..." and then I installed Realteck audio soft for audio driversYou can comfortly identificate your sound driver by:

  1. go into the "device manager"
  2. then go into the "properties" of the driver...
  3. click on the tab "specifics" and here change "description of the device" into the "identification of the hardware"
  4. copy there the first title (it must look like this "HDAUDIO\FUNC_01&VEN_8086&DEV_2806&SUBSYS_80860101&REV_1000)...
  5. paste it into the web browser and some pages will tell you what is it and what driver is for this device. (my recommendation is realtek for audio drivers) (and also u can easiely identify every device and driver for them thru this procedure.

that was first step... if you got realtek soft installed, first step is not needed.

Second step: is reinstall one of the "Sound, game and video controllers" and its called (I translated it from my language of windows) " Intel (R) Voice for dysplays"

  1. go to "properties"
  2. go to tab "driver"
  3. click on "backup changes of the driver"
  4. and then "actualize driver"

At the end try to connect HDMI and test it if it is working. GL HF ;oD

share|improve this answer
add comment

TL;DR: In short, some sound devices seem to have multiple profiles and each of these profiles might expose different outputs to the Ubuntu sound settings dialog; but they can be switched by the PulseAudio Volume Control GUI.

Install pavucontrol, run it via the GUI or a CLI, and switch to the configuration tab where you'll see dropdowns for every output containing their respective sound card profiles.

In our case, one of them was HDMI; and now on the sound settings configuration dialog, the option for HDMI output appears.

Source: My girlfriend had come across this issue on her first day of using Ubuntu on her HP laptop. The solution for her was to follow Charlie Schams's suggestion at http://askubuntu.com/a/234784/69183.

share|improve this answer
    
I only see 2 options, HMDI and None, and none of them work. –  YatharthROCK May 18 at 7:49
add comment

I've just solved my own problem after reading through all other threads like you stated.

I right clicked on the bottom right speaker icon, clicked playback devices and when the window popped up I right clicked in a blank space under the speaker device and selected Show all disabled devices and then enable the devices I wanted to use.

share|improve this answer
4  
Are you using Ubuntu? An anonymous user has pointed out (in a suggested edit) that these seem like Windows instructions. –  Eliah Kagan Jul 24 '12 at 4:36
add comment

I ran into exactly the same problem and followed one of the threads to install the proprietary graphics driver. Then the HDMI option appear in the hardware sound setting window. It finally worked.

To install the proprietary graphics driver:

  • Click the system settings icon on your desktop.
  • Click Additional Drivers under Hardware.
  • Activate the driver.
  • Restart your system.
  • You should see the HDMI option appears in the sound window. Click to select the option.

Since I did this, I hear the audio coming out of my TV.

share|improve this answer
1  
Santosh is using integrated intel graphics. Therefore you don't have to install proprietary drivers. –  Ethan Leroy Oct 20 '12 at 16:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.