Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need to check if I have updates for Ubuntu. I think it is 12.04

As you can see this is what it says:

Failed to download repository information  Check your Internet connection.


W:Failed to fetch cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Release amd64 (20120425)/dists/precise/main/binary-amd64/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
, W:Failed to fetch cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Release amd64 (20120425)/dists/precise/restricted/binary-amd64/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
, W:Failed to fetch cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Release amd64 (20120425)/dists/precise/main/binary-i386/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
, W:Failed to fetch cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Release amd64 (20120425)/dists/precise/restricted/binary-i386/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
, W:Failed to fetch http://ppa.launchpad.net/ferramroberto/java/ubuntu/dists/precise/main/source/Sources  404  Not Found
, W:Failed to fetch http://ppa.launchpad.net/ferramroberto/java/ubuntu/dists/precise/main/binary-i386/Packages  404  Not Found
, E:Some index files failed to download. They have been ignored, or old ones used instead.
share|improve this question
Thank you for posting the exact error message, but the obvious question now is: did you check your internet connection and what was the result? You could open a browser and see if your internet connection works. –  elmicha Jun 16 '12 at 19:59
It appears that the main repos responded, so i doubt some proxy thingy here. <wild guess> –  Mahesh Jun 17 '12 at 7:44
add comment

6 Answers 6

up vote 0 down vote accepted

Well, I recommend checking your internet connection. Just open Firefox and see if your start page loads. If you are not connected to the internet, try to connect to a Wifi network. If your computer has no Wifi capabilities, or lacks the necessary drivers, plug an ethernet wire into your computer.

share|improve this answer
This message is for: (Jaxkr) Well thats the problem and i only have Chromium Web Browser, i just click and my WIFI is fine!!!! –  Luca Brazza Jun 17 '12 at 18:04
wifi is fine!!! –  Luca Brazza Jun 27 '12 at 16:11
add comment

I had this problem and after changing the server from the update manager (from my country to us or main server) it worked just fine. Try a server near you or the main one and see if it works

enter image description here

Edit: Uncheck CD-ROM enter image description here

share|improve this answer
This Message is for: (Remus Rigo), Sorry mate that dosnt work! Details are above on the description above –  Luca Brazza Jun 17 '12 at 18:09
open a terminal and try to ping google (ping -c 3 www.google.com) and post the result –  Remus Rigo Jun 18 '12 at 4:54
luca@luca-oneTwo-L5861:~$ ping -c 3 www.google.com PING www.l.google.com ( 56(84) bytes of data. 64 bytes from we-in-f147.1e100.net ( icmp_req=1 ttl=44 time=35.4 ms 64 bytes from we-in-f147.1e100.net ( icmp_req=2 ttl=44 time=34.6 ms 64 bytes from we-in-f147.1e100.net ( icmp_req=3 ttl=44 time=37.7 ms --- www.l.google.com ping statistics --- 3 packets transmitted, 3 received, 0% packet loss, time 2003ms rtt min/avg/max/mdev = 34.663/35.976/37.770/1.313 ms luca@luca-oneTwo-L5861:~$ –  Luca Brazza Jun 21 '12 at 15:32
go to: Ubuntu software center - > Edit -> Software Sources and uncheck CD-ROM –  Remus Rigo Jun 21 '12 at 20:37
There is no Edit, and can i remind you my system is 12.05 –  Luca Brazza Jun 27 '12 at 16:13
show 2 more comments

What those errors are saying

I have seen your error message and The problem is for the deactivated PPA. The PPA is no longer exists!. You can check this manually by trying to go to this link


This is the link, from which apt trying to load the source index file. As the PPA is offline, It is giving a 404 error. Though Your internet is fine.

Also Try to go to this PPA's home page in launchpad. You can see that, there is not activity or build for your Ubuntu version i.e 12.04 aka Precise Pangolin.

And The error with cdrom's are for the fact that, those entries becomes invalid. You have to re add those cdroms. I am giving solutions to both problems.

Solution for the error with PPA

The solution is remove the software source line from your system.

  • First check your /etc/apt/sources.list file by opening it in a terminal with command sudo gedit /etc/apt/sources.list to see any line with containing that link. It should look like this.

    deb http://ppa.launchpad.net/ferramroberto/java/ubuntu precise main
    deb-src http://ppa.launchpad.net/ferramroberto/java/ubuntu precise main

    If you see any line, containing this, remove the line completely and exactly only that line.

  • If there wasn't any line like that, the PPA source file is in /etc/apt/sources.list.d directory. In that case, remove that file by the following command

    sudo rm /etc/apt/sources.list.d/ferramroberto-java-precise.list

Solution for the error regarding CDROM entries

  • Open a terminal and type software-properties-gtk and hit Enter

  • In the opened window, in Other software tab, Click on the "cdrom" entries and and hit Remove button to remove corrupted apt cdrom source.

    enter image description here

That's it. Try now sudo apt-get update to see the error was removed.

If you want to add a CDROM again as a Software-Source, See these Links.

share|improve this answer
This fixed the CDROM issue for me. Thanks! –  Oliver Joseph Ash May 31 '13 at 9:13
add comment

Are you conected to internet? if so and guive you that error, try this: Try to change the server selecting update manager, definitions,downloading from, then select a server more near you. and then try to check your updates again.

share|improve this answer
Thats exactly what i told Remus Rigo, that dosnt work, sorry mate Details are above on description above –  Luca Brazza Jun 17 '12 at 18:10
Sorry mate! I didn't read correctly your answer! –  Celso Jun 19 '12 at 0:13
add comment

I had the same problem on Xubuntu 12.04, for several days. Changing the server and unchecking the CD-ROM box indicated in previous answers did not solve it.

I opened the Synaptic Package Manager and clicked on Settings > Repositories. Under the Ubuntu tab, the same CD-ROM box appeared and was unchecked. Under the Other Software tab there were a half-dozen lines mentioning CD-ROM. I unchecked, then Removed them all. Closed that window and clicked Reload on the main window. This seems to have solved the problem for me, since the Update Manager now says "The package information was just updated" (it used to be 10 days out-of-date and refused to update when I had the problem). Now clicking the Check button in the Update Manager finishes without complaints about the Precise cdrom.

share|improve this answer
it didnt work sorry –  Luca Brazza Jun 30 '12 at 8:35
add comment

I have faced this problem before. It may due to network proxies. You may check the network proxies!

share|improve this answer
This answer would be much improved if you edited it to explain how to check the network proxies. –  Eliah Kagan Jul 21 '12 at 17:15
add comment

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.