Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I don't have any technical knowledge of Ubuntu but wanted to install it on a partition. Step-by-step of what i did.

  1. used disk management in windows 7 to clear 50gb of space
  2. used a usb live ubuntu 12.04 installer in custom install mode
  3. used the installer's built in disk manager to set up 2gb swap space and 48gb ext4 space
  4. ran installation, with option to copy over documents and settings from windows 7
  5. restarted after completion.

After this, my computer automatically loads ubuntu 12 and skips the option to load windows 7. i know the files are still there, as i can see them in the file manager. When trying to fix with the win7 installer dvd it tries to repair the OS in drive [D:] i.e. it recognises the disc itself as the OS and ignores the [c:] files.

I think, after browsing around here, similar problems suggest this is a problem with the boot loader, but if the win7 dvd won't work, then i don't have any way to fix this. does anyone know of a way to force the computer to show a "choose OS" screen?

share|improve this question
    
What happens when you hold the shift key after the exiting the BIOS? GRUB should show up and give you the ability to choose what to boot. You can configure GRUB by editing /etc/default/grub, here you can also make GRUB displaying the "choose os menu" at startup (should be default actually). –  user244 Jun 16 '12 at 18:57
    
i tried using shift. it didn't help. also, how does one go about editing the grub file? –  Léon McGregor Jun 16 '12 at 19:18
    
here is your solution. I was also facing same issue. askubuntu.com/questions/341620/… –  STEEL Sep 5 '13 at 15:28

2 Answers 2

You didn't specify your boot manager of choice.

If you want windows to manage the boot menu, it wouldn't recognize Ubuntu directly without a 3rd party boot manager like easybcd. If you want Ubuntu to manager the boot menu, you need to load grub2.

Source: http://superuser.com/questions/392033/no-boot-menu-after-installing-ubuntu

Grub needs to be fixed (Re-Installed). The link below shows you how to do just that.

Click here for a step-by-step instructions for using Grub.

Reinstall / Recover GRUB from Ubuntu live CD / USB

share|improve this answer
    
I don't think Leon wants to replace GRUB with the Windows Boot Manager, for some reason GRUB boots directly into Ubuntu instead of showing the menu. –  user244 Jun 16 '12 at 18:59
1  
fernmann is right. the problem is that grub completely ignore windows. i have tried using the "update grub" temrinal command and that didn't solve it. –  Léon McGregor Jun 16 '12 at 19:06
    
I understand, I'm just giving him a option. –  Mitch Jun 16 '12 at 19:06
    
i had a look, mitch, but i have no idea what the step-by-step guide is saying. [sorry] –  Léon McGregor Jun 16 '12 at 19:07
    
its telling you how to repair or re-install Grub, by using the live CD. –  Mitch Jun 16 '12 at 19:08

SOLUTION:

  1. Your harddrive needs to be in MBR format, also Disable UEFI on laptop bios. Since, 12.04 Grub 1.99 wont know how to write BOOT FILE in this mode.
  2. I formated my HDD from GPT to MBR with help of MiniTool Partition Wizard 7 Bootable USB.
  3. Start installation again, sda1 ext4 partition with 100GB. path: /
  4. Swap base: 4296MB
  5. Rest space formated with ext4, PATH: /home

In case, you face BCM-kernal-source issue for make ur wireless card NOT working do the following in terminal after successful installation. Plug in Ethernet wired connection and below in terminal;

wget http://de.archive.ubuntu.com/ubuntu/pool/restricted/b/bcmwl/bcmwl-kernel-source_6.20.155.1+bdcom-0ubuntu6_amd64.deb
sudo dpkg -i bcmwl*.deb
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.