Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just installed a wireless USB driver using ndiswrapper. The icon and menu options "says" I'm connected; meaning that I'm able to disconnect, connect, etc., but Firefox is not connecting to the internet. One thing I did change was that for some strange reason Firefox appears to have been set by default to be in "work offline" mode; which well, is an interesting default.

Do I need to enable something; the http port for example?

If not, how do I isolate the source of the issue? For example, attempt to do a "ping google.com" from the terminal, but appears Ubuntu didn't like that syntax.

Thanks, and if you have any questions, just let me know!

share|improve this question
1  
Can you please give us the error message you got when typing ping google.com in the terminal. I ask because there should be no errors - at least not from the syntax. –  Takkat Nov 27 '10 at 22:11
    
@Takkat: The output from "ping google.com" is "ping: unknown host google.com" –  blunders Nov 27 '10 at 22:33
1  
What if you ping 209.85.135.147? Are you able to ping your router? How is your DHCP set up? What DNS do you use? You see - there are plenty of possibilities ;) –  Takkat Nov 27 '10 at 22:46
    
@Takkat: Pinged the Google IP you gave (which was a great idea) and got this message: "connect: Network is unreachable" -- no idea how to ping a router, check the DNS, or DHCP; though I have no control over the router, since it's a public access point, it works just fine using the same hardware on Windows. –  blunders Nov 27 '10 at 23:14
    
@Takkat: Might add that the all the access point wifi names are being displayed on the drop down in 10.04, just appears that I'm not able to connect; though I am on Windows. –  blunders Nov 27 '10 at 23:16
show 1 more comment

2 Answers 2

up vote 2 down vote accepted

WLAN access points being listed but a connection cannot be established may have many different reasons starting from incomlete installation of wpasupplicant (try latest version) to missing to incompatible network settings.

Check if the encryption setting (wireless security tab) for your neighbourhood are correct. If on a public AP you may not need any encryption.

I have a wired connection so unfortunately cannot give you a screenshot for wireless settings. I include a shot for wired LAN where at least some points are similar: alt text

Access to network settings is right click on the network manager icon. Choose your connection then "Edit..". Note your setting in case you need to restore them. The tab IPv4 settings gives you access to DHCP settings where it should say "Automatic (DHCP)". From the tab IPv6 setting you can set "Method" to "Ignore" as you most likely don't use IPv6. In the unliely event that your AP does not provide DNS services you can add your own by choosing "Automatic(DHCP) adresses only" from IPv4 settings.

This may not solve your specific problem but gives you ideas where to start from. You may also find solutions here.

share|improve this answer
    
Thanks, I've given up on getting Ubuntu working for now, it's taking to much time, and I've got way more important thing to focus on. Selecting you as the answer, since you've been a huge help and your answer is clearly a step in the right direction. I had taken a look at the Edit option, and had noticed the "Last Used" column as being marked as "never" which at the very least means I never got a connection. Again, thanks -- and cheers! –  blunders Nov 28 '10 at 20:11
add comment

hello try this 1) Open Firefox 2) In address bar, type about:config 3) Search/Filter for "offline" 4) Toggle off (double-click) browser.cache.offline.enable

share|improve this answer
    
"browser.cache.offline.enable" if it's false just turns off caching. Appears after checking in the Windows version Firefox that what I saw as a setting "work offline" is just Firefox telling me it does not have an internet connection. +1 for the attempt to help though, thanks! (If I'm missing something, which is possible just let me know.) –  blunders Nov 27 '10 at 21:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.