Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using ubuntu 12.04 and my video card is ATI Radeon 5000. I cannot use double screen (extended version). I get this error

The selected configuration for displays could not be applied requested position/size for CRTC 148 is outside the allowed limit: position=(1280, 0), >size=(1280, 768), maximum=(1440, 1440)

I tried all display settings but it does not work.

Some outputs from the system settings:

root@ubuntu:~# lshw -C display
       description: VGA compatible controller
       product: Madison [Radeon HD 5000M Series]
       vendor: Hynix Semiconductor (Hyundai Electronics)
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=fglrx_pci latency=0
       resources: irq:46 memory:e0000000-efffffff memory:f0020000-f003ffff ioport:d000(size=256) memory:f0000000-f001ffff
root@ubuntu:~# aticonfig --initial 
Uninitialised file found, configuring.
Using /etc/X11/xorg.conf
Saving back-up to /etc/X11/xorg.conf.original-0
root@ubuntu:~# cat /etc/X11/xorg.conf
Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0

Section "Module"
    Load  "glx"

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    BusID       "PCI:1:0:0"

Section "Screen"
    Identifier "Default Screen"
    DefaultDepth     24

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24

I would appreciate any suggestions how to solve the problem. Thank you

share|improve this question
up vote 3 down vote accepted

Actually are trying to fix this in the wrong place Go to termial and type sudo amdcccle It will open a AMD catalyst Center Window, There you can go and displays, check the right resolution for your displays and then reboot.Everything will work like a charm!


share|improve this answer
It solved my problem, thank you:) Just a note for the people who has the same/similar problem. I typed "sudo amdcccle" (one c was missed on the code above). "Display Manager" > selected "Multi-display desktop with diplays(s)". – johan Jun 16 '12 at 15:38
Sorry for the mistake. :/ – Vinit Kumar Jun 16 '12 at 15:44
Take note that if you have disabled the "Mirror displays" in the Ubuntu display settings, you need to reenable it for Control Center to function appropriatelly. – Septagram Dec 5 '12 at 16:27

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.