Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running servers on the Rackspace Cloud -- the first-generation one, not the next-generation Open Stack one. I believe it's running Xen for the hypervisor.

I use the stock images from Rackspace. I primarily use 10.04 servers, but I've also been rolling out new servers with 12.04.

My problem is that I want to keep the kernel up-to-date. I can apt-get dist-upgrade for new kernels, and the installation works fine. However, when I reboot, the server doesn't come back up.

My guess is that there's some custom hackery around the grub configuration that makes the stock kernels work, but upgraded kernels fail.

Has anyone had a similar problem on the Rackspace Cloud? What's the smallest modification I need to make grub boot a new kernel?

share|improve this question
    
Take a look at gist.github.com/2938618 it may help you. –  calas Jun 17 '12 at 17:30
    
Please pastebin the output of dmesg, ls /boot, and after installing imvirt, its output. –  izx Jun 21 '12 at 22:08
add comment

1 Answer

up vote 1 down vote accepted

You need to edit /etc/default/grub and alter it to exclude UUIDs from the root device. ie.

Open a terminal by pressing Ctrl+Alt+T and enter:

gksu gedit /etc/default/grub

Find and uncomment the following line. That is remove the # from the beginning of the line # GRUB_DISABLE_LINUX_UUID=true like this:

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
GRUB_DISABLE_LINUX_UUID=true

Save and exit from gedit.

You then need to run update-grub to affect these changes by entiering:

sudo update-grub

The root device in use on rackspace in something like /dev/xvda1, which is not a UUID but this is treated as one by grub. Consequently at the next boot grub searches for a device with that UUID and cannot find it, hanging the boot process.

share|improve this answer
    
I've updated the answer, hopefully thats better –  Sam Jan 14 '13 at 11:26
    
This did it! Great answer. –  Evan P. Jan 24 '13 at 16:36
    
Also: I tried this out on the HP Cloud, which is also an Open Stack cloud, and it worked, too. –  Evan P. Jan 25 '13 at 19:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.