Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Ubuntu 12.04 can be started in console mode (without GUI) by adding the file /etc/init/lightdm.override with the content manual:

echo manual | sudo tee -a /etc/init/lightdm.override

When I start Ubuntu in console mode, however, there are three odd things happening:

  1. The command startx reads my .xsession file (rather than .xinitrc).

  2. My .Xmodmap with key mappings is no longer read.

  3. When I exit X Windows the computer hangs with a black screen.

Any clues?

share|improve this question
Unless there is something particular you're trying to do with lightdm, the canonical way to boot into the console is to simply add change the kernel boot options from quiet splash to text -- startx works perfectly then. – izx Jun 16 '12 at 10:31
I have tried that too but it gives me the same result. – August Karlstrom Jun 16 '12 at 10:57
Instead of startx, try sudo service lightdm start.. – izx Jun 16 '12 at 11:00
My reason for booting into console mode is that I want to start X Windows without using a display manager (like lightdm). – August Karlstrom Jun 16 '12 at 11:08

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.