Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Today, I downloaded the 3.2.0-25 kernel as suggested by Software Update.

After restart, my wireless isn't working, doesn't even show up in the Network Manager.

If during boot, I choose the previous kernel 3.2.0-24, everything is hunky dory

My machine is an HP h9xt with a RT5390STA wireless card.

Andrew

share|improve this question
    
Which version of Ubuntu? 12.04 ? –  david6 Jun 16 '12 at 7:34
    
I have same problem at the last time, but I can solved it by directly download the driver from www.ralinktech.com. Don't use the driver from the CD. May be it have been expired. And I use this site for my case. –  klox Jun 22 '12 at 10:20
    
Thanks izx, your guide has helped resolve an issue with my Asus X54C laptop. It has an Ralink RT5390 network card but was using the wrong driver resulting in very slow network speeds and constant network drop-outs. I had to make a change to the config.mk settings that you specified: HAS_NATIVE_WPA_SUPPLICANT appears to have been renamed to HAS_NATIVE_WPA_SUPPLICANT_SUPPORT - the following command work: Change the WPA2 variable: WPA2=HAS_NATIVE_WPA_SUPPLICANT_SUPPORT I also had to blacklist the rt2800pci driver and then reboot: echo "blacklist rt2800pci" | sudo tee -a /etc/modprobe.d/blacklist. –  Tom Mar 15 '13 at 22:30

1 Answer 1

You'll have to rebuild the driver module for your card. Here's how:

  • Your adapter has a Ralink RT5390 chipset. You can download the official Linux drivers from this site. Save them to your Downloads folder (default):

    enter image description here

  • Open a terminal with Ctrl-Alt-T, and paste the following, line by line:

    sudo apt-get install linux-headers-$(uname -r) build-essential
    cd Downloads
    tar -xjf 2011_0406_RT5390_RT5392_Linux_STA_V2.5.0.3_DPO_GPL.bz2
    cd 2011_0406_RT5390_RT5392_Linux_STA_V2.5.0.3_DPO
    WPA1=HAS_WPA_SUPPLICANT
    WPA2=HAS_NATIVE_WPA_SUPPLICANT
    sed -i -e "s/$WPA1=n/$WPA1=y/g" -e "s/$WPA2=n/$WPA2=y/g" os/linux/config.mk
    sudo make && sudo make install && sudo make clean
    cd ..
    
  • Reboot, and hopefully your wireless connection will work!

  • Then open up the Downloads folder in the File Manager and delete the downloaded Ralink file/folder:

    enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.