Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
8 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up unity-2d-common (5.12.0-0ubuntu1.1) ...

(gconftool-2:13920): GConf-WARNING **: Failed to load source "xml:merged:/tmp/gconf-pfTj8n/gconf": Failed: Could not make directory `/tmp/gconf-pfTj8n/gconf': Permission denied
**
GConf:ERROR:gconftool.c:969:main: assertion failed: (err == NULL)
dpkg: error processing unity-2d-common (--configure):
 subprocess installed post-installation script returned error exit status 250
dpkg: dependency problems prevent configuration of unity-2d-panel:
 unity-2d-panel depends on unity-2d-common (= 5.12.0-0ubuntu1.1); however:
  Package unity-2d-common is not configured yet.
dpkg: error processing unity-2d-panel (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of unity-2d-spread:
 unity-2d-spread depends on unity-2d-common (= 5.12.0-0ubuntu1.1); however:
  Package unity-2d-common is not configured yet.
dpkg: error processing unity-2d-spread (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of unity-2d-shell:
 unity-2d-shell depends on unity-2d-common (= 5.12.0-0ubuntu1.1); however:
  Package unity-2d-common is not configured yet.
dpkg: error processing unity-2d-shell (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of unity-2d:
 unity-2d depends on unity-2d-panel; however:
  Package unity-2d-panel is not cNo apport report written because the error message indicates its a followup error from a previous failure.
                                                           No apport report written because the error message indicates its a followup error from a previous failure.
     No apport report written because MaxReports is reached already
                                                                   No apport report written because MaxReports is reached already
                                                 No apport report written because MaxReports is reached already
                               No apport report written because MaxReports is reached already
             No apport report written because MaxReports is reached already
                                                                           onfigured yet.
 unity-2d depends on unity-2d-spread; however:
  Package unity-2d-spread is not configured yet.
 unity-2d depends on unity-2d-shell; however:
  Package unity-2d-shell is not configured yet.
dpkg: error processing unity-2d (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of unity-2d-launcher:
 unity-2d-launcher depends on unity-2d-shell; however:
  Package unity-2d-shell is not configured yet.
dpkg: error processing unity-2d-launcher (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of unity-2d-places:
 unity-2d-places depends on unity-2d-shell; however:
  Package unity-2d-shell is not configured yet.
dpkg: error processing unity-2d-places (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of unity-2d-dbg:
 unity-2d-dbg depends on unity-2d (= 5.12.0-0ubuntu1.1); however:
  Package unity-2d is not configured yet.
dpkg: error processing unity-2d-dbg (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 unity-2d-common
 unity-2d-panel
 unity-2d-spread
 unity-2d-shell
 unity-2d
 unity-2d-launcher
 unity-2d-places
 unity-2d-dbg
E: Sub-process /usr/bin/dpkg returned an error code (1)

I've tried a lot and can't get this working. I think I interrupted an install and it just screwed it all up. I've googled and tried various fixes.

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

Try this. Press Ctrl-Alt-F1 to switch to a terminal (you can switch back to your desktop with Ctrl-Alt-F7). Log in, and type:

  • sudo apt-get remove unity-3d-common unity-2d-panel unity-2d-spread unity-2d-shell

And then:

  • sudo apt-get update && sudo apt-get upgrade

If that doesn't work, please edit your question with the output of this command: dpkg --list | grep unity

share|improve this answer
    
Ok I removed those and now I get no errors... but don't I need those packages? –  HungryMan Jun 16 '12 at 4:48
1  
That simply removes the unconfigured/half-configured versions of those packages that were causing the error. The original versions should still be there, and upgraded correctly when you try now. –  izx Jun 16 '12 at 4:51
    
Not done yet. I'm getting an error again. One of them is still stuck - unity-2d-common. edit: OK it's working now. Thanks a ton! –  HungryMan Jun 16 '12 at 6:08
    
Happy to help, please post back if you have any other problems :) –  izx Jun 16 '12 at 6:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.