Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to play League of Legends via Wine which I managed to get a stable 60 fps from, there are just a couple problems I am encountering.

Whenever the actual game starts, Wine disables my second monitor. I can easily turn it back on without any problems using:

xrandr -s 0

Option 0 being the 3360x1050 option.

I have found a couple of ways to solve this but all seem to have drawbacks.

  • If I switch from TwinView to Xinerama Wine doesn't disable my second monitor but then I only get about 12 FPS. I read that this is because Xinerama disables graphics acceleration.
  • If I set Wine up to run a virtual desktop this works except this means I cannot run in fullscreen. Perhaps there's a way to make the virtual desktop fullscreen by default? I can set the resolution to 1680x1050 but I will still have the gnome-panel bars appear at the top and bottom.

I wonder perhaps if there is a way for me to remove the 1680x1050 option from xrandr and only have the 3360x1050 option?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

I run things in a Desktop mode. It's essentially a window that Wine is constrained to. You can do this on an application-by-application basis or you can do it for everything.

The nice thing about both approaches is that if the resolution is equal to the resolution of a screen, it's displayed in fullscreen mode (without decorations, above panels, etc) so it appears to take over a whole screen, without bodging around the actual display settings.

Just one application

Change your launcher to something like this:

wine explorer /desktop=LIMBO,1920x1200 "C:\Program Files\LIMBO\LIMBO.exe"

In the /desktop=LIMBO,1920x1200 part, LIMBO is just the title for the window and 1920x1200 is the resolution.

For everything in a Wine prefix

Run winecfg and go to the Graphics tab. Check the "Emulate a virtual desktop" and enter a resolution. From now on when you run something in that prefix, it'll load in a virtual desktop.


I personally use a mix. My default Wine prefix doesn't force it all the time but there are some single applications I run through explorer /desktop.... Other things (like PlayOnLinux bottles) are just easier to configure with winecfg.

share|improve this answer
    
Okay, I just tried adding the explorer /desktop extension to my launcher and this works. It wasn't working earlier when I used winecfg to do the same thing. (The panels weren't being hidden). Hurrah, I can finally play LoL on Ubuntu :) Thank you. (I can't mark you as an answer as I don't have enough rep :C ) –  Lerp Jun 16 '12 at 1:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.