Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell Precision M6600 and installed Ubuntu 12.04. The cursor jumps around all by itself when I'm not even touching the keyboard. When I try to type the cursor goes crazy and clicks and jumps all over the place making it impossible to type; eventually it freezes and I can't type, click or use the key board. Any ideas on how to fix this?

share|improve this question

3 Answers 3

I had this same problem and it took me weeks to figure out what was going on. I thought it was an issue with the mouse, the touchpad, etc.

Finally it dawned on me - its the stinking touchscreen (not sure why Dell decided it would be a good idea to put a touchscreen a desktop replacement laptop).

In any event, you can disable the touchscreen using xinput. I wrote the following little script that I use to turn mine off :

#!/bin/bash

function showUsage() {
  echo "

  usage : $0 [-on|-off]

  "
}


TOUCHSCREEN_ID=`xinput list | grep "Touchscreen" | cut -c 55-57`
TOUCHSCREEN_ID2=`xinput list | grep "N-Trig MultiTouch" | cut -c 55-57`

TOUCHSCREEN_FLAG=`xinput list-props $TOUCHSCREEN_ID | grep "Device Enabled" | cut -c 24-`

if [ $TOUCHSCREEN_FLAG == 1 ] ; then 
  TOUCHSCREEN_FLAG=0
else
  TOUCHSCREEN_FLAG=1
fi


case $1 in 
  "-on") TOUCHSCREEN_FLAG=1 ;;
  "-off") TOUCHSCREEN_FLAG=0 ;;
  "--help") SHOW_USAGE=1 ;;
  "-?") SHOW_USAGE=1 ;;
esac   


if [ "$SHOW_USAGE" == "1" ] ; then 
  showUsage
  exit -1
fi   



xinput set-prop $TOUCHSCREEN_ID "Device Enabled" $TOUCHSCREEN_FLAG
xinput set-prop $TOUCHSCREEN_ID2 "Device Enabled" $TOUCHSCREEN_FLAG
share|improve this answer

Same problem here. Dell came and replaced the touchscreen, touchpad, keyboard, motherboard, and some electronic harnesses to no avail. It's practically a new computer now! I've upgraded all the drivers and still have the problem.

One workaround is: go to Control Panel, select "N-Trig DuoSense Digitizin Settings"; on the Digitazer options tab, select "Pen Only" and click apply. This eliminates and disables the touchscreen via human touch but still active by stylus. Not sure what the real solution is, but sure hope someone figures out the real problem. It used to work nicely and now this problem which even Dell hasn't been able to fix.

share|improve this answer

Juan, do you have the nvidia graphics card? That's what I have. I think it's a problem with the graphics drivers. T

he cursor goes especially crazy when the background is black or a very dark color. I've installed Ubuntu 12.04, OpenSuse 12.1 and 12.2, Fedora 17, Ubuntu Studio 12.04 thinking that one of the operating systems might solve the crazy cursor jumping promblem which it did as long as I left the nouveau drivers, As soon as I install the orginal nvidia drivers to expoit the grahics card as much as I can because I work with 3d animation, the cursor starts to go nuts again.

I tested the all the versions of the ndvidia drivers, including older versions. It seems as though nvidia doesn't give any support whatsoever.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.