Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed GNOME Shell on my 12.04 a couple hours ago.
The notifications are just cool, and I installed shell extensions, and it works smoothly in 1 hour.
Then I restarted my computer for some reason, start back in to GNOME.
And I was surprised with the default notification showed up.
It replaced the GNOME notifications!

Notification

I tried to:

  1. Reinstall gnome-shell. (autoremove and install)
  2. Reset desktop configuration.

But it didn't work at all.
Is there anything I can do to fix it?

Plus: I got a double notification (osd + gnome notification showed up) when someone chatted me.

share|improve this question
    
Please, someone, any help would be appreciated. This is really annoying ( -_-)" –  Drie Jun 15 '12 at 19:30
    
I am having the same problem. I think this could be related to recent updates as the problem did not start until I installed updates that went out on Wednesday (6/13). –  Ruslanchik Jun 15 '12 at 23:11
    
I see, thanks for the information :) –  Drie Jun 16 '12 at 5:08

3 Answers 3

up vote 0 down vote accepted

Are you still having this problem? After an update this weekend I was getting Unity and Gnome notifications, sometimes for the same events. Then, I installed updates today and the problem seems to be fixed.

share|improve this answer
    
2 days ago, the problem was fixed right after I restart my system due to system updates. And it worked fine, until I restarted my system the second time. This problem came back to my system. I don't know why. :( –  Drie Jun 21 '12 at 17:03
    
Oh, I just updated my system again hours ago, and it's now fixed, even with a couple restart, thanks again for your info. :) –  Drie Jun 21 '12 at 23:10

Try modifying /usr/share/dbus-1/services/org.freedesktop.Notifications.service, basically it tells the system to open notify-osd if you are using a unity, unity-2d or a gnome-session.

Since I don't have unity, I just replaced both cases to notification-daemon

share|improve this answer

Try sudo apt-get remove libnotify4 libnotify-bin notify-osd this could remove Unity notification system.

share|improve this answer
    
Oops, something's not right. When I try to run that command, it says a lot of things. There are so much packages to be removed and to be installed. Even unity, nautilus, and update-notifier are to be removed?! Sorry, but I think your answer didn't helped me :( –  Drie Jun 16 '12 at 5:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.