Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This seems to be a common problem with 12.04. I've done the searches and found various and sundry replies, but I've yet to find a solution to my situation.

I've installed 12.04 32bit on a server box I have in my office, and am using it to get used to Joomla CMS, but I cannot seem to do updates, upgrades with it, nor can I use Aptitude to get new software. The machine will not authenticate against the repos is what I'm thinking.

It works fine as long as I have DHCP set up, but when I go to a static IP situation it falls flat. I have networking working perfectly other than this.

As far as I can tell, it's in the nameservers from my ISP not propogating into resolv.conf.

Here is my /etc/network/interfaces file contents: :~$ cat /etc/network/interfaces # This file describes the network interfaces available on your system # and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface  \  these stanzas are kept in order
#auto eth0                        \ for me to easily switch between dhcp
#iface eth0 inet dhcp             / and static addresses so I can update
#                                /  the system from time to time

auto eth0
iface eth0 inet static
address 192.168.1.130
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1
dns-namservers 75.75.75.75 75.75.76.76 192.168.1.1
dns-search hsd1.wa.comcast.net

#nameserver 75.75.75.75         \  this data is taken
#nameserver 75.75.76.76          \ from resolve.conf
#nameserver 192.168.1.1          / while networking with
#search hsd1.wa.comcast.net     /  dhcp instead of static ip

For the life of me I cannot figure out why this is not working. I'm totally missing something fundamental here I think.

The Search stanza is working, and shows up properly inside resolv.conf:

search hsd1.wa.comcast.net

I'd really appreciate anyone's help on this.

share|improve this question
3  
Not sure if it's just a copy error: dns-namservers should be dns-nameservers (you missed an e) –  charlesbridge Jun 15 '12 at 20:19
    
Brother, I can't seem to mark this comment as the answer...but it most assuredly is! When I was younger I used to think there was something magickal about the hours from 12am to 5am, writing some code or doing research. Now that I am older I find that this is no longer the case. Thank you SO much for proof-reading my bs. My server is happily humming along now and I can install my PHP additions so Joomla will be a happy camper! –  Olympic Softworks - Dave Jun 16 '12 at 17:09
1  
You can now mark the community wiki answer created from it as the accepted answer. –  Eliah Kagan Jul 11 '12 at 17:14
add comment

2 Answers

up vote 6 down vote accepted

Per Charles' comment: "dns-namservers" should be dns-nameservers (you missed an "e").

share|improve this answer
add comment

I have this issue in ubuntu 12.04 installed in virtualbox inside ubuntu 10.04. For me helped disabling IPv6 in 12.04 that runs inside virtualbox (right click network tray icon in upper right corner >> edit connections >> your connection name [wired connection 1 in my case] >> open last tab "ipv6" settings and select method "ignore")

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.