Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently, I tried to reconfigure GRUB to boot kernel 3.2 instead of 3.4, but by booting, GRUB is not responding to any changes I make in the grub.cfg file. Editing /etc/default/grub and updating it with update-grub doesn't bring any errors and changes and ends with done.. Kernel 3.4 is always booting, whatever I do. Google is speechless.

share|improve this question
2  
Please post your /etc/default/grub and your /boot/grub/grub.cfg (as it looks immediately after running "update-grub" with the /etc/default/grub that you post). Also, why do you have a 3.4 kernel installed if you don't intend to use it by default? Do you plan to sometimes use it or could it just be removed to simplify things? –  Jordan Uggla Jun 15 '12 at 18:22
add comment

2 Answers

Default grub menu entry can be switched using GRUB_DEFAULT in /etc/default/grub file. If your kernel 3.2 entry is 7th in the list - the easiest way to set to default would be making following change in /etc/default/grub:

GRUB_DEFAULT=7

And then executing sudo update-grub2 to update grub configuration.

share|improve this answer
    
This answer is the result of the comment thread. Question needs to be updated. –  Andrejs Cainikovs Jun 15 '12 at 18:13
add comment

If you really have kernel version 3.2 installed in your system, it will be added to grub menu automatically after you do

sudo update-grub

Hope this helps.

share|improve this answer
    
OP already wrote that update-grub does not help. –  Andrejs Cainikovs Jun 15 '12 at 17:16
    
GRUB doesn't react to any updating, but grub.cfg changes. Kernel 3.2 is the 7th entry in the menu. Setting it to default doesn't work. Trying to set timeout doesn't work either. –  stef Jun 15 '12 at 17:18
    
@Andrejs Cainikovs This means that the conditional clause in my answer is not satisfied [properly]. –  Vitalie Ciubotaru Jun 15 '12 at 17:19
    
@AndrejsCainikovs yes, it exists and is chosen in grub.cfg, but by rebooting, just 3.4 boots without letting my choose between versions. no reaction, that's the problem. –  stef Jun 15 '12 at 17:25
    
@stef, now I'm lost. As per your last comment - you cannot select the 3.2 entry? I am right? –  Andrejs Cainikovs Jun 15 '12 at 17:28
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.