Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I leave my PC alone for while the screens turns black, which is fine. When I return and move my mouse it comes back on but my second screen stays black and my first screen has a blue overlay over the top of the unlock screen.

I believe this is to do with my dual screens on gts450.
screen 1 is 1920*1080
screen 2 is 1024*768
The blue overlay is on screen one and looks to be the size of screen 2

I can put the password in and press enter and then everything goes back to normal, but how do I fix this issue of a blue overlay stopping me seeing whats on screen?

share|improve this question
    
Does this happen with ubuntu 12.04? Which version are you currently using? Have you tried booting with ubuntu 12.04 live cd/usb and check if the same thing happens? –  medigeek Jun 16 '12 at 11:19
add comment

2 Answers 2

This is a bug. There is already a bug report in launchpad, although launchpad might not the right place for it (probably this is a gnome-screensaver bug and has to go upstream).

https://bugs.launchpad.net/gnome-screensaver/+bug/1061787

share|improve this answer
    
If the downstream bug has the necessary details to make a good upstream bug, then anyone can go ahead and post an upstream bug based on it and linking to it. Downstream in Launchpad, it can be connected to the upstream bug report with "Also affects project". –  Eliah Kagan Jan 3 '13 at 19:03
    
@EliahKagan Yeah, you are right. It wasn't worth it to mention this here. I added "gnome-screenshot" already as "affected project" but did not write add upstream bug, because I'm not sure enough about the problem and the other bug reports. I'm still quite newbie here. I'm currently working on it, I'll try to add more information then. –  lumbric Jan 3 '13 at 19:26
add comment

What is your current driver version installed on Ubuntu? Which version of Ubuntu are you using? Something you could try is to open up your X server settings and going to OpenGL Settings and making sure the check box with VBlank is checked. (This works for NVIDIA) I believe AMD works like this also.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.