Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having some problems, my computer is shutting down at random intervals, but from today it started to shut off rigth after the login screen.

It's a Toshiba Laptop. I thought it was the cpu overheating, but it's not. I tried also different RAMs and it won't work either.

Then I was thinking that it could be related to the ACPI but I tried adding the "acpi=off" in the boot/kernel and it shut off again.

So I really have no idea about what's happening. I still can boot in recovery mode but with the CLI only, as soon as I issue "startx" it'll shut down, sometimes instantly and other times after 1 o 2 minutes.

Other thing I tried was booting live from an USB drive. It also shut down, after the GUI showed and the drive lost its booting capabilities.

Do you have any ideas?

share|improve this question
    
Can you please tell what Toshiba laptop it is? Please give as much detail as possible (eg: it has a Hybrid graphics system intel + dedicated gpu) What version of Ubuntu are you using? 32 or 64 bit? Please answer and I will be able to give you a better answer to solve your problem. –  Brask Jan 9 at 16:35
add comment

1 Answer

Maybe it's not the CPU overheating, but still the CPU. What you describe is exactly what I experienced a couple of weeks ago. I then ran memtest and everything, even plugged in a graphics card (as prior to boot the screen was messed up, sometimes instead of shutting down it simply froze). Finally I booted from several CDs to make sure it was not the installation messed up. Trying with a Linux Mint 12 CD lying around, it booted in text mode and there it was: The big error message which never made it into any log file, CPU0 being out of sync, kernel panic. So try booting from a CD and see what is displayed on the console (I didn't see that when booting from the hard disk into recovery mode of Ubuntu, but that may have been sheer accident).

share|improve this answer
    
And how did you fix it? did you get a new CPU? –  Marcos Ciarrocchi Jun 15 '12 at 16:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.