Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just installed vanilla Xubuntu 12.04 LTS & updated on a ThinkPad E325 with Conexant CX20671 sound card. I notice volume hotkeys work under Xubuntu DE but not under XFCE. Sound settings are completely missing under XFCE.

Bubble bar invoked by +/- hotkeys, is greyed out; though volume slider that resides in system tray still functions. Muting/decreasing/increasing volume with hot keys has no effect.

Is there a workaround? If not what package would I report a bug against?

PS: I'm running 64-bit.

PPS: It just goes through the motions under XFCE DE, GUI volume will rise & fall, but actual audio will not change. (This is due to hotkeys being mapped wrong; see below.)

share|improve this question
add comment

3 Answers

up vote 3 down vote accepted

Is it may be same issue? How to switch 'default' sound device controlled by hardware keys in Xubuntu?

You should check, that 'active-card' in xfce4-mixer settings is proper.

share|improve this answer
    
I think that could well be the solution! Will try it. –  fleamour Jun 26 '12 at 2:26
    
The volume hot keys were indeed mapped to HDMI. Followed above guide then Sound Settings ==> Configuration to toggle HDMI off. –  fleamour Jun 26 '12 at 3:13
add comment

As detailed on this community documentation wiki page, press Alt+F2 and run this command:

ubuntu-bug audio
share|improve this answer
add comment

et in to Alsa Mixer and check out your audio controls and look em over, same times its gets idle and you have to tutch the mixer and , this usualy works for me (xfce Arch kernel 3.6.9rc7 amd64) and (Xubuntu 12.04 kernel 3.5.x amd64) (Gentoo 3.6.0 xfce TI64 )

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.