Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Ubuntu server 10.04 LTS. It worked great for many months, until today I decided to run fsck on the system partition and although it warned me, I kept pressing yes and now it will only boot into grub prompt.

I read some article that recommended trying grub reinstall. But before performing grub reinstall, i decided to run fsck again from Ubuntu 10.04 LTS for desktop live CD. The fsck painfully passes, now my drive is recognized as ext4 system and I am able to mount it again. However, all i can see is just boot directory and lost&found. I tried to perform grub reinstalling by doing grub-install stuff, now my grub is still not loading right, my files are missing, and the weird thing is that the amount I found used by boot and lost n found is only 5gb and the amount used in he hdd is 8 gb.

So my files must be somewhere in the hdd.

Is there any simple way maybe a GUI tool or something that can recover my files? I only need to retrieve my database backup and everything else can go.

share|improve this question
What fdisk -l gives? – jasmines Jun 15 '12 at 12:41
I have a backup drive from october 2011. The exact image of the same drive with the same directory structure. I backed it up using clonezilla. Can that somehow help to remap the drive correctly and recover my files? If so, how? Fdisk -l returns sda1 as swap drive 14gb, sda2 as core (my drive name) 140gb. Before fsck this partition was not recognized – cinlung Jun 15 '12 at 14:42
Itried to look into lost and found, i can only find old files not the latest ones.i have not tamper withthe partition nor write anything into it except fsck filling up the lost and found and rebuilding the grub... Which failed – cinlung Jun 15 '12 at 14:51
Will foremost works with linux live? Or is there similar tool under windows? The only linux system i have is the broken server :( – cinlung Jun 15 '12 at 15:05
@cinlung Did you ever have any luck with this? – belacqua Jan 30 '13 at 18:28

Foremost may be able to find the files you care about. I used it to help a friend extract files from a drive that had physically failed with some unrecoverable sectors.

share|improve this answer

In general I'd suggest burning and booting a live CD such as Ubuntu or SystemRescueCD and using extundelete to recover any deleted files.

share|improve this answer

It is time to restore from backup. Failing that, it sounds like your files are in /lost+found so you will need to look through there and try to identify them ( their original names have been lost ).

share|improve this answer

I recently had a coworker recover data using 'scalpel'. You can see some info on it and others here: . This is the Ubuntu community documentation for Data Recovery.

Currently, it also covers

  • Ubuntu-rescue-remix
  • Gnu parted
  • testdisk
  • Gnu ddrescue
  • foremost
  • magic rescue
  • photorec
  • ntfsprogs
  • autopsy
  • sleuthkit

and a few others.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.