Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After updating to 12.04, I cannot use the mouse buttons. I have a work around to be able to drag with the touchpad alone, also to use the touchpad for right click. I would however like to use the actual buttons to drag and drop and actually right click. I have an Acer Aspire S3 series laptop. Does anyone know why this may be happening and how I can fix it?

share|improve this question

2 Answers 2

This is the fix for right click on a touchpad with no buttons i.e. a clickpad!!

create a folder:

/etc/X11/xorg.conf.d/

the create a file called 51.synaptics.conf

open gedit in root and save the file in the above folder with the following text in the file:

Section "InputClass"
Identifier "Default clickpad buttons"
MatchDriver "synaptics"
Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
EndSection

log out and then log back in again and you will have right click

if you do not have a clickpad and have actual buttons see what your touchpad is capable off:

xinput -list (to find the name of your touchpad)

then:

xinput list-props "SynPS/2 Synaptics TouchPad" | grep Capabilities

you should see some output like this:

Synaptics Capabillities (295):  1, 0, 0, 1, 1, 1, 1

the numbers mean the following:

(1) device has a physical left button
(0) device does not have a physical middle button
(0) device does not have a physical right button
(1) device does support two-finger detection
(1) device does support three-finger detection
(1) device can configure vertical resolution
(1) device can configure horizontal resolution

if I was you I would take a look at the my comment and follow the link, this should help solve your problem.

share|improve this answer
    
    
I do have hard buttons. when I pull up the xinput, the device is actually "ETPS/2 Elantech Touchpad" and it pulls up as 1,0,1,1,1,1,1. When I click the right button, it gives the same effect as a left click. –  Kent Larsen Sr. Jun 21 '12 at 5:51
    
if you have an acer aspire S3 then you have what is called in linux terms as a clickpad. see if clickpad is enabled by using the "synclient -l" command. if its set to Clickpad = 0, then it is not recognising that you have a clickpad. Change this by issuing the following command: synclient Clickpad=1. to make it permanent you can add the command to the startup applications. –  oneofthemany Jun 22 '12 at 8:26
    
outside of the above you could try the following: sudo modprobe -r psmouse && sudo modprobe psmouse proto=imps. then to make it permanent: sudo gedit /etc/modprobe.d/options then add options psmouse proto=imps. once you have done this save the file and then issue the following command: sudo update-grub: linlap.com/wiki/acer+aspire+s3 –  oneofthemany Jun 22 '12 at 8:36
    
Note: i would always recommend using man synaptics and synclient to configure your touchpad as you have more flexibility for control and adjutsments. –  oneofthemany Jun 22 '12 at 8:41

If your touchpad is not recognised as a clickpad [linux term for a touchpad with soft button areas] you can use the following 51.synaptics.conf file:

Section "InputClass"
Identifier "Default clickpad buttons"
MatchDriver "synaptics"
Option "ClickPad"         "true"
Option "EmulateMidButtonTime" "0"
Option "SoftButtonAreas"  "50% 0 82% 0 0 0 0 0"
EndSection
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.