Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.04 on a Toshiba satellite. I also installed LibreOffice 3.5.3.2 (along with Tamil language related packages). I downloaded the required m17n packages.

I am able to choose the iBus framework, choose the tamil99 "input method", and type in Tamil when I run Gedit and also in the terminal window. But, I am unable to do so in LibreOffice (right clicking doesn't show any input method menu item) and Thunderbird.

Thanks for any pointers you may be able to provide.

share|improve this question
    
Did you ever get this solved completely? I just installed iBus on Kubuntu, and am having a similar problem (it works in Kate, but not Firefox, Konsole, Sublime, etc.) I found a claim here that it's the customizations to the Ubuntu iBus package that are causing the problems, and the "normal" Debian one works fine...? –  Owen_R Nov 11 '13 at 10:14
    
Yes, I have been using Tamil99 in LibreOffice, Firefox, Thunderbird, and gedit for some time now without difficulty in Ubuntu 12.04. I thank everyone who posted responses to various queries. I'll post my "solution" at the end of this series. - Ramki (T. Ramakrishnan) –  T. Ramakrishnan Nov 13 '13 at 12:16

7 Answers 7

Thanks for those who suggested possible solutions.

The following suggestion works for LibreOffice, gedit, and terminal. (It still doesn't work in Thunderbird, though.)


http://user.services.openoffice.org/en/forum/viewtopic.php?f=16&t=37863&sid=6cd6626c2ec5ddf283d4d6043b11acfb

Re: Language issues after switching to Standard OOo

Postby Robert Tucker » Fri Jan 28, 2011 3:08 pm Have you tried:

$ export XMODIFIERS=@im=SCIM

$ export GTK_IM_MODULE=scim

$ export QT_IM_MODULE=scim

$ scim -d


share|improve this answer

Open Keyboard Input methods and go to Advanced tab.

Select the checkbox next to Share the same input method among all applications.

You should now be able to type in Tamil in both Gedit and LibreOffice Writer at the same time.

enter image description here


If you don't want to use the same input method across all applications, one simple solution would be to just momentarily the change input method when you are typing in Tamil.

To do that, just press Ctrl+Space and the input method would have changed to Tamil. Just ensure that the iBus indicator has changed to this icon: enter image description here

share|improve this answer
    
Thanks, but I'd already done that. When libreoffice is the only application that's open and I click on the keyboard icon, it says "no input window". When i open gedit, it shows tamil99 and I'm able to type in Tamil. But, not in LibreOffice. –  T. Ramakrishnan Jun 17 '12 at 1:26
    
When you are on Libreoffice, press Ctrl+ Space to change the input method. It is generally more reliable than clicking on the menu and changing it. –  jokerdino Jun 19 '12 at 7:18
    
Thanks, again. And, again, I'd already tried that, too. (I didn't want to mention all the details when I filed the request. Maybe I should have! Sorry about that.) Until I switched to Ubuntu 12.04, I was using SCIM and I was able to type in Tamil99 in LibreOffice. (I received Tamil99 help from Mr. Sivaraj back in 2009 or so.) I recently learned that ibus is the preferred method (rather than scim). I tried scim after ibus failed. But, that didn't help, either. –  T. Ramakrishnan Jun 21 '12 at 2:14

I have been using Tamil99 in LibreOffice, Firefox, Thunderbird, and gedit for some time now without difficulty. I thank everyone who posted responses to various queries. - Ramki (T. Ramakrishnan)

A) I received the following instructions from my friend, Karuna. These are an improvement over what I'd found earlier using help from those who posted replies to my query.

  1. System Settings -> Language Support For Keyboard Method Settings, Choose ibus and then click Install/Remove Languages and choose Tamil.

  2. From Dash Home, type Keyboard Input Methods and you will get the iBus Preferences Window.

Click 'Show Input Method name on language bar' and then under Input Method choose Tamil99.

  1. Logout and login or to be safe, just restart the machine.

  2. Now go to any application like gedit, LibreOffice, Thunderbird and type in English and then do Control+Space and then you will be able to type in Tamil. There will be a visual keyboard on the top menu bar when input language is English, and Tamil 'Tha' when typing in tamil.

I am not able to type many tamil characters in the shell; they show up as "boxed" (strange) characters.

The confusing part is that there is a System Settings -> Keyboard Layout which just has one entry now (English) and I don't need to do anything here (If I wanted to use some other keyboard like Tamil Unicode or Tamil TAM, then I could add that keyboard here, but since there is no support for Tamil99 here, we don't change anything here.)

You must not select "Use this method for all applications" in "Input Methods".

B) In order for the above procedure to work, we need to do the following first. (I'm not sure if we need all of the following libraries!)

Start Ubuntu Software Center. Search for m17 Install m17n-db, m17n-contrib, ibus-m17n. Install m17n-im-config, m17n-lib-bin.

Logout and log back in.

C) Everytime I boot the system or login, I start ibus.

Then press ctrl-space to switch between Tamil99 and English.

I couldn't make the daemon work so I am doing this everytime. In other words, the following didn't work for me when I tried it a while ago: Go to Dash Home. Click "Startup Applications". Add Task Command: /usr/bin/ibus-daemon -d

----------- End of text.

share|improve this answer

While in Libre Writer, Press Ctrl+Space after enabling ibus and then change the font to Lohit Tamil from the default Lohit Hindi.

share|improve this answer

The below worked for me.

If IBus does load but doesn't see LibreOffice as an input window, add this line to ~/.bashrc:

export XMODIFIERS=@im=ibus

And then, you need to start ibus with --xim -d, for example, add this line to ~/.xinitrc:

ibus-daemon --xim -d

But the horrible thing is that you need to start LibreOffice in terminal.

share|improve this answer

You can check the solution here: https://wiki.archlinux.org/index.php/IBus#LibreOffice

export OOO_FORCE_DESKTOP="gnome"
share|improve this answer

I had the same problem and found the solution

apt-get install libreoffice-gtk

launch again libreoffice and voila!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.