Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using DVORAK layout and I want to switch to QWERTY but apparently this is not possible via GUI settings and it stuck on DVORAK Is there any way to completely reset keyboard layout? I am using ubuntu 12 04 and I have this problem in both KDE and GNOME thanks

EDIT: the indicator on the top bar in GNOME is also messed up. I have another layout (persian (fa) ), but, when I switch between layouts with keyboard shortcuts, it is English(DVORAK) when the indicator is fa (and is not en), and vice versa.

share|improve this question
add comment

4 Answers

You can open the System Settings Menu by typing

gnome-control-center

on the command line. You will find a Icon called Keyboard Layout.

share|improve this answer
    
I've tried this, but adding a default keyboard layout adds DVORAK instead of QWERTY. –  Keyhan Asghari Jun 15 '12 at 10:12
add comment

With KDE4, similar handling: Open the "System Settings", and with the "Input" section you will find "Keyboard layouts". There you have to first enable the layouts (so the settings become editable), add the QWERTY you want to have, remove the old Dvorak, and then you can disable layouts (including the keyboard indicator) again.

Granted, that was easier with KDE 3.5 -- but once you know how it works, it is at least do-able.

share|improve this answer
    
I've tried this, but adding a default english keyboard layout adds DVORAK instead of QWERTY. –  Keyhan Asghari Jun 15 '12 at 10:20
    
Did you check all the additional settings available there, like "keyboard variant" etc? That's the place where to select QUERTY with or without dead keys, or Dvorak, or whatever. –  Izzy Jun 15 '12 at 10:30
    
Yeah, I tried them. the problem is that there is no keyboard with QWERTY, there's only default options, that they are DVORAK in fact. I am wondering is there any way to reset all these settings completely to their default forms? I can't find that, and the reset and defaults items which exist in GUI keyboard settings does not do the right job. –  Keyhan Asghari Jun 15 '12 at 12:31
1  
I'm currently not near any Ubuntu machine, but tried Google a bit. You could check with your X config in /etc/X11/xorg.conf.d/30-keyboard.conf (the number may differ) and see if you find out the variant set there. For Dvorak, it should be something like Option "XkbVariant" "dvp". If you found that, comment it out (which should revert it to its default). That's just a "better guess" as I cannot verify it currently, but in the hope it may help... –  Izzy Jun 15 '12 at 13:14
    
I haven't /etc/X11/xorg.conf.d directory, so I made it and placed the file 30-keyboard.conf, then filled it with the content given here: bbs.archlinux.org/viewtopic.php?id=129615 (I replaced fr with en) then, restarted X, but still nothing changed!:( –  Keyhan Asghari Jun 15 '12 at 13:30
show 2 more comments
up vote 2 down vote accepted

I just deleted the .xmodmap file from my home directory, and everything is fixed.

share|improve this answer
add comment

I had a similar problem now, being stuck with German keyboard with all deadkeys. First I used my above solution which seemed to work fine -- but after reboot, it reverted back. After a lot of google-ing around I finally found a solution: become root, and type

dpkg-reconfigure keyboard-configuration

which brings up the initial keyboard configuration dialog you were presented with at installation time. So it lets chose you everything: language, keyboard-variant, and also specialities like if you want Ctrl-Alt-Backspace used to kill the X-Server, or which key to use as compose key (for those who don't know: a useful thing, as the name suggests it allows you to compose a character of two characters, e.g. compose+/ then o brings the nordish ø, or compose+" then i brings ï, etc.).

Be aware, however, that this change is system-wide (i.e. applies to all users on the system) -- which in most of our cases is no issue either ;)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.