Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing Skype 4.0 on Ubuntu Precise, I see its indicator in top bar, but there is no running application icon on the left, thus I can't focus into it and pin to the Launcher.

I had 2.2 version before, but purged it as described in Skype 4.0 still looks like 2.2 beta, so I believe this can be considered clean install.

Related question is whether it's possible to have overlay with new/unread messages in the unity launcher icon similar to indicator?

share|improve this question
    
Try to start a chat from the menu that opens clicking the icon in unity panel. Doing this, I see the icon in the launcher. –  jasmines Jun 15 '12 at 9:05
    
There was no icon at all, but appeared after I rebooted. In combination with skype-wrapper it works as expected. –  Igor Semenko Jun 15 '12 at 17:50
add comment

4 Answers 4

I have equal behavior with skype icon. But, after using "apt-get install" from command line to install skype, this problem was resolved.

You should try to install skype using "apt-get install", if it's not that.

More over, this installation method is recomended instead of skype website.

sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update && sudo apt-get install skype

I've found it here:

https://help.ubuntu.com/community/Skype

share|improve this answer
add comment

You have to install sni-qt Install sni-qt package:

If your Ubuntu is 32 bits:

sudo apt-get install sni-qt

Or, if you are using 64 bits:

sudo apt-get install sni-qt:i386

I'm not sure if you need to logout / login afterwards, but Skype will then appear together with other indicators.

share|improve this answer
    
This solves the problem even in Gnome fallback mode (non-Unity). –  pts Mar 7 '13 at 10:07
add comment

It's actually back to what it used to be (in early versions of Ubuntu), so you need to 'whitelist' the notification icon.

Take a look at http://www.webupd8.org/2011/04/how-to-re-enable-notification-area.html (or google 'skype whitelist ubuntu'.

share|improve this answer
add comment

Consider the missing launcher a benefit and install skype-wrapper, which integrates Skype nicely into Unity:

sudo add-apt-repository ppa:skype-wrapper/ppa
sudo apt-get update && sudo apt-get install skype-wrapper

See this article for further details: http://www.omgubuntu.co.uk/2012/05/skype-wrapper-adds-call-actions-notification-fixes-ubuntu-12-04-support

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.