Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Skype 4.0 following this guide. However my little Skype icon in the unity status bar (in the top right corner with clock, volume, etc.) is gone. How do I get it back?

share|improve this question
    
Have you tried this solution from this question? –  WarriorIng64 Nov 3 '11 at 17:58

8 Answers 8

up vote 84 down vote accepted

You may need to do two things:

1. Install the sni-qt libraries.

Install sni-qt Install banshee (click on the link), or with sudo apt-get install sni-qt sni-qt:i386 from the terminal, and then restart Skype. The tray/panel icon should now be back!

The reason this step is required is because sni-qt is installed automatically by the Ubuntu repository Skype package, but NOT by the Skype deb you directly download. Once Skype 4.0 is in the Ubuntu repos, you can install from there and this will no longer be necessary.

2. You may also need to whitelist the indicator

We don't know why, but for some systems this additional step is required before the indicator will show (thanks to Bruno Pereira!)

Steps:

  1. Install the package dconf-toolsInstall dconf-tools (click on the link), or from the terminal with sudo apt-get install dconf-tools

  2. Open dconf editor from the Dash (or dconf-editor from terminal):

    enter image description here

  3. On the left sidebar, use the triangles to navigate to desktop > unity > panel. On Ubuntu 12.10 you instead need to navigate to com > canonical > unity > panel. Double-click on the orange [JavaEmbedded...] part on the right, and add ,'skype' to allow the Skype indicator to show, as below:

    enter image description here

  4. Press Enter, close dconf editor, logout and login -- your indicator should now be back!

share|improve this answer
2  
This solution works for me thx –  miceterminator Jun 15 '12 at 6:51
8  
In Ubuntu 12.10 I found it at a different path within dconf-editor: com > canonical > unity > panel. –  aecolley Oct 29 '12 at 21:25
2  
On Ubuntu 12.10 you do not have a panel item under unity. :( One Zero's answer works though. –  Ali May 11 '13 at 11:32
2  
As of 13.04, both com > canonical > unity > panel and desktop > unity > panel are not there. IMO the right solution is to install skype from repository as described here –  deville Jun 8 '13 at 9:03
2  
Can confirm this works great on 13.10, and I didn't need to whitelist it. Just installing that package and quitting then starting Skype again fixed it :) –  Andrea Faulds Oct 31 '13 at 22:44

Enable Skype Icon on Unity Notification Panel on Ubuntu 12.04 LTS

When you do a fresh install of Ubuntu 12.04 (Or any version with Unity for that matter), you install Skype and expect it to work as it used to. But if you close the main window - you soon notice that Skype icon is not being displayed in top panel.

To fix this you will need to run a few commands. So open up your terminal and run this:

gsettings get com.canonical.Unity.Panel systray-whitelist

You should get something like this:

['JavaEmbeddedFrame', 'Wine', 'Update-notifier']

Basically this means, that Skype is not whitelisted, thus is not allowed by default to display its tray icon. We need to fix this. Append 'Skype' to the list so that you have something like this:

['JavaEmbeddedFrame', 'Wine', 'Update-notifier', 'Skype']

Then wrap it with double quotes (”) and add gsettings set com.canonical.Unity.Panel systray-whitelist in front of it. At this point you should have something like this:

gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Wine', 'Update-notifier', 'Skype']"

Now just copy this to your Terminal and execute the command. Reboot afterwards. Now you should see the icon.

Source enter link description here

share|improve this answer
    
Thank you for providing the commands b/c when I open DConf editor I don't see a Panel option under Unity. This worked well for me after I also installed sni-qt (not sure that was required). –  kingdango Dec 21 '12 at 13:12
2  
After the first command: No such schema 'com.canonical.Unity.Panel'. Ubuntu 13.04 64-bit. –  Hubro Jun 30 '13 at 16:42
    
Same here: "No such schema" Ubuntu 13.04 64 bit –  Luis Lobo Borobia Aug 15 '13 at 6:52
    
Here: Systray on Ubuntu 13.04 webupd8.org/2013/05/how-to-get-systray-whitelist-back-in.html –  Luis Lobo Borobia Aug 15 '13 at 6:56

maybe you need to whitelist skype to the notification area (i'm not sure if skype includes an appindicator)

The easy way to make it is installing dconf-tools

sudo apt-get install dconf-tools

or Using Software Center Install via the software center

Then press alt+f2 and enter dconf-editor to see a program like this:

dconf-editor

Navigate to desktop-->unity-->panel and add the apps that you like to whitelist to the end of the list (in your case you must add 'Skype') separate by comas. You can instead write all to whitelist all apps to use the notification area.

You will need to log out and log in again yo apply the changes.

More info: http://www.webupd8.org/2011/04/how-to-re-enable-notification-area.html

share|improve this answer

Reference

Here I post you an article that explains how to include Skype in a Unity system tray whitelist.

I have Ubuntu 12.04, it worked for me!

Details

Basically, open a new terminal and execute this:

gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Wine', 'Update-notifier', 'Skype']"

and then restart Skype.

share|improve this answer

If your are using gnome shell, activate this extension call Status Icon Fixer

Fixes Dropbox, Skype, vlc and others into the status bar; not perfect, but ok.

https://extensions.gnome.org/extension/192/status-icon-fixer/

share|improve this answer
1  
For Ubuntu 13.10 and newer, Status Icon Fixer reportedly does not work any more. I use the alternative Top Icons extension for 13.10 and it works well. –  tanius Feb 17 at 17:55

Go to the Skype->Options.

In the General Category check "Start Skype minimized in the System Tray".

share|improve this answer
    
nope that didn't change anything. But the option is (in german) rather labeled start minimized (says nothing about the system tray). So now I just have to click two times on the button in the Launcher –  miceterminator Jun 15 '12 at 6:47

For me the path in dconf editor was:

com -> canonical -> indicator -> appmenu -> messages

And then click on applications and in value add 'skype'. I'm running Ubuntu 13.10 (64-bit).

share|improve this answer

I think Ubuntu developers should set default value "systray-whitelist" to "all". Before setting it to "all", in my Ubuntu 12.04.2, even Google Chrome and Copy (Cloud software) icons were not visible on panel. (Thankfully Dropbox icon was there.) An End user won't like to do such tweaking just to have an icon visible on panel. And I think these days people have enough screen resolutions to include all icons they have on panel.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.