Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to improve the battery life of my Asus U32U notebook. I'm running Ubuntu 12.04 64bit and using powertop it shows the following:

PowerTOP 1.97     Overview   Idle stats   Frequency stats   Device stats   Tunables   

Summary: 311.6 wakeups/second,  0.0 GPU ops/second and 0.0 VFS ops/sec

Power est.      Usage       Events/s    Category       Description
  6.29 W    100.0%                      Device         Radio device: asus-nb-wmi
  1.19 W    100.0%                      Device         Display backlight
    0 mW     49.3 ms/s      42.8        Process        compiz
    0 mW     19.5 ms/s      51.4        Process        /usr/bin/X :0 -auth /var/run/li
    0 mW     10.3 ms/s      16.8        Process        gnome-terminal
    0 mW      5.5 ms/s     118.1        Interrupt      PS/2 Touchpad / Keyboard / Mous
    0 mW      2.0 ms/s      37.0        Interrupt      [45] fglrx[0]@PCI:0:1:0
    0 mW      1.6 ms/s       0.4        Process        powertop
    0 mW      1.5 ms/s       1.1        Process        /usr/lib/unity/unity-panel-serv
    0 mW      1.0 ms/s       4.5        Timer          tick_sched_timer
    0 mW      1.0 ms/s       9.3        Process        syndaemon -i 2.0 -K -R -t
    0 mW      0.9 ms/s      20.3        Timer          hrtimer_wakeup
    0 mW      0.8 ms/s       0.2        Process        [flush-ecryptfs-]
    0 mW      0.7 ms/s       0.9        Process        /usr/lib/gnome-settings-daemon/
    0 mW    697.3 µs/s       0.2        kWork          rfkill_poll

According to this Ubuntu community help page the asus-nb-wmi driver is responsible for implementing the function keys, something I can definitely live without if it means I will get longer battery sessions.

So I would like to know if its possible to disable the asus-nb-wmi when not plugged in to AC power, and if so, how.

share|improve this question
add comment

2 Answers

I have a similar asus laptop. However, on mine it's called "asus_nb_wmi". I just use

    sudo rmmod asus_nb_wmi

to disable, and then

    sudo modprobe asus_nb_wmi

if i want to reenable it and be able to use function keys to control the volume level again.

share|improve this answer
add comment

Add this line to your /etc/modprobe.d/blacklist.conf:

blacklist asus-nb-wmi

That will disable loading asus-nb-wmi on boot.

share|improve this answer
1  
This question is about how to disable asus-nb-wmi just while running from battery power. Blacklisting the module will disable it always. –  Eliah Kagan Jun 20 '12 at 12:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.