Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I use Fn+F6 / F7 (brighness down and up on Toshiba) the brightness notification opens up and responds, but the actual screen brightness remains unchanged. When I go to Settings > Brightness and adjust the slider, the same happens.

lspci reports my single graphics card: 01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Mobility Radeon HD 2400

I noticed both actions are taking effect on /sys/class/backlight/toshiba/brightness. When I manually change /sys/class/backlight/acpi_video0/brightness though, the screen finally lightens/darkens accordingly.

toshset reports "required kernel toshiba support not enabled." Installing toshiba-acpi-fix from ppa:keks9n/main doesn't work - install fails with: "Reloading the module ERROR: Module toshiba_acpi does not exist in /proc/modules FATAL: Error inserting toshiba_acpi (/lib/modules/3.2.0-25-generic/kernel/drivers/platform/x86/toshiba_acpi.ko): No such device"

(By the way, I only tried toshset because I saw it suggest elsewhere it could help diagnose the problem. I have no intent or reason to install toshiba-acpi-fix unless it fixes the brightness issue.)

How do I make the system write to the right brightness control file? Is there any way to get rid of the invalid directory entry?

(By the way 2 folders in Sys/Class/Backlight? didn't help me.)

share|improve this question
    
Hopefully you get a good answer to this. In the meantime, you might try to work around by creating keyboard shortcuts to a program/script that directly alters /sys/class/backlight/acpi_video0/brightness –  Sepero Jun 15 '12 at 1:12
add comment

1 Answer

up vote 1 down vote accepted

OK, between attempting suggested changes I left a acpi_backlight=vendor on the Grub command line. My command line Grub variables now read

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="splash"

My xorg.conf has the following on Device Section:

Option "RegistryDwords" "EnableBrightnessControl=1"

And everything is working as it should.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.