Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I disabled PulseAudio to be able to use my microphone for Skype, and now the volume controls don't work, which I understand, is a common problem.

I read that somebody fixed their Skype microphone by going to system setting > multimedia > phonon > audio recording > prefer webcam microphone.

I'd like to try that, but I think I need to enable PulseAudio again. How do I do that?

I used the following guide on Skype's support pages to disable PulseAudio: Can I change the sound system used by Skype for Linux?

share|improve this question
    
I tried installing Pulse Audio from the Ubuntu Software Center and it did install, but now when I try to click on the Volume Control, it says: Fatal Error: Unable to connect to PulseAudio:OK. so I can't even access Pulse Audio, and it's not even visible in the System Monitor.... –  rux Jun 15 '12 at 0:03
    
How did you disable pulse audio?. Did you remove that from your system? –  Anwar Shah Jun 15 '12 at 8:49
1  
I disabled it according to Skype's suggestions here support.skype.com/en-us/faq/FA10964/… and then set up ALSA –  rux Jun 15 '12 at 14:26

3 Answers 3

Re-enabling PulseAudio autospawn

What you did by following the guide, was to prevent PulseAudio to start automatically when you login to your account. If that worked for you, than changing autospawn=no to autospawn=yes should also work. I would prefer doing this from the terminal (Ctrl+Alt+T) by running the following command:

sed -i 's/autospawn=no/autospawn=yes/g' ~/.pulse/client.conf

Now you just need to reboot or logout and login to let the changes take effect.

Configure Skype

The guide you followed didn't setup ALSA, but configured some sound devices to specifically use ALSA devices instead of the default device or something else. So, going to Main Menu > Options > Sound Devices and revert the settings back to default will get you back to the starting point.

Are you using KDE/Kubuntu or Unity/Ubuntu?

I want to point out that Phonon is a component from the KDE desktop. If you are not using KDE/Kubuntu, then installing KDE might not be the straightest solution to fix your issues.

share|improve this answer

You can re-enable the pulseaudio by deleting the folder .pulse and the file .pulse-cookie in your home directory. Then logging out and login again.

Enable viewing hidden files:

If you are using Dolphin file manager of Kubuntu, Press Alt+. to see hidden files and folder.

In Nautilus, (If you are using default Ubuntu) The shortcut is Ctrl+H.

or just do this on a terminal window

pulseaudio -k 

or

killall pulseaudio

and then

pulseaudio --check 

to check if any instances are running

share|improve this answer

Actually, Skype docs recommend using Pulsaudio: Link

By default, pusleaudio is not started, I put in Startup applications.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.