Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had Ubuntu 11.04 running till now. Now I want to reinstall Ubuntu with nearly fresh 12.04. I had much trouble last time to install Ubuntu because of EFI. Yet somehow I somehow got it running. But I can't remember how.

Now I have a gpt partition with my personal data on sda4, an EFI partition on sda1 and between a swap and a root partition. I want to install Ubuntu on the root partition without clearing the hole SSD.

Everytime I try to install ubuntu my "BIOS" can't find it. When I press the right key at the right time I get an overview over the possible booting options. There is a "grub" entry but when I enter it I get to the overview again after a redraw of the display.

I tried all possibilities for the bootloader section (yes I installed Ubuntu 5 times today) and have no clue how to get my system running again. I also tried repairing grub via chroot. What should I do?

edit: Yes the installation completes without error. But as far as I can tell grub isn't even loaded. I would say my computer knows it should start grub, but can't excess the ssd. Or it doesn't find what it is looking for. And this behaviour didn't change by installing elilo(though I can't tell if I did it right). Grub is usually going to some shell when started with errors, but here simply nothing happens.

share|improve this question
    
I got it. I finally installed ubuntu and it starts. What was the trick? I deleted the existing EFI partition and the following swap partition and made them new as efi (not as fat16) and swap. And I configured the bootloader to install on the efi partition. –  pirad Jun 14 '12 at 22:52
    
Could you give us the output of sudo parted -l so people aren't just guessing about your current partition layout, it will definitely shed some light for us. EDIT: You may need to boot into a live version of Ubuntu and run that command, since your having trouble booting into Ubuntu (sorry, should have specified this earlier). –  hazrpg Dec 24 '12 at 8:48

3 Answers 3

If I understand correctly, your problem is that your boot loader is broken after Ubuntu installation has completed; when you launch GRUB from your firmware, it dumps you back to the firmware's boot manager. If that's incorrect (if you're having problems getting the installer to start, for instance), please clarify.

My recommendation is that you install another boot loader. In my experience, GRUB 2 is the least reliable of the available Linux boot loaders, and when it malfunctions, it's usually easier to replace it than to try to fix it. If this is a Linux-only system, I recommend you try ELILO. If you're dual-booting with Windows, either use ELILO in conjunction with rEFInd or try Fedora's patched GRUB Legacy. You can install any of these from the Ubuntu installer in its "try before installing" mode, but you may need to do a sudo apt-get install efibootmgr followed by use of that tool to add the new boot program to the firmware's list of boot programs. See my Web page on EFI boot loaders for more information, including details of how to use efibootmgr.

The drawback to doing this is that you'll need to manage your boot loader manually; the scripts for updating the boot loader when you update your kernel will no longer work. Thus, you'll have to be sure to upgrade your boot loader configuration whenever you upgrade your kernel.

share|improve this answer
    
Outstanding answer. Definitely will be a reference for my future Win7 computer purchases. Though now I normally remove original HDD altogether when I buy a computer and use an SSD. –  Chris K Jun 14 '12 at 19:56
    
I have to disagree with Grub2's unreliability. I have never had a problem with GRUB, even through changing hard disk layouts, partition layouts, and using the same hard disk with Grub on three computers. –  hexafraction Jun 14 '12 at 20:26
1  
@ObsessiveFOSS Out of curiosity, how much of your experience with GRUB2 was using it together with GPT and UEFI? –  irrational John Jun 14 '12 at 23:35
    
GRUB 2's reliability varies greatly from one computer (or even one installation on one computer) to another. On some systems it works fine. On others it never starts up, or produces a grub> prompt, or the boot process hangs partway through on some boots but not on others. In my experience, the kernel's EFI stub loader, ELILO, and Fedora's patched GRUB Legacy are all more reliable as EFI boot loaders, at least speaking broadly. System-to-system variability is huge, though, so on some systems GRUB 2 is fine, or may even be superior to the others. In other words, YMMV. –  Rod Smith Jun 15 '12 at 2:59
    
I had set up a system for a friend with GPT and UEFI, and although I was a bit more cautious than usual, that person reported no problems with it(Disclaimer: doesn't guarantee they didn't have problems I never heard about). My two Ubuntu computers just used MBR. –  hexafraction Jun 15 '12 at 11:58

Grub works great installed to a disk with GPT partition tables, however in order to install to a GPT partitioned disk that disk must have a small (1mb is plenty) partition especially for grub. (on msdos partitioned drives there is a space that grub uses, but that is not present on GPT partitions). Recent versions of gparted is able to make these small partitions. Unfortunately, if your drive was partitioned without this partition you are quite out of luck, as moving a partition even a single megabyte is a large ordeal. https://www.gnu.org/software/grub/manual/html_node/BIOS-installation.html

Grub 2 support booting from GPT even from a BIOS, as not not require UEFI native mode. All non-apple x86 computers I know of support booting in BIOS mode, and this is recommended over UEFI booting.

share|improve this answer
up vote 0 down vote accepted

As I wrote in the comments the answer for me was to delete the existing EFI partition and the following swap partition and make them new as efi (not as fat16) and swap. And I configured the bootloader to install on the efi partition.

sudo parted -l gives (german):

Modell: ATA C300-MTFDBAK128M (scsi)
Festplatte  /dev/sda:  128GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: gpt

Nummer  Anfang  Ende    Größe   Dateisystem     Name  Flags
 1      17,4kB  200MB   200MB   fat32                 boot
 3      200MB   3888MB  3688MB  linux-swap(v1)
 2      3888MB  27,9GB  24,0GB  ext4
 4      27,9GB  128GB   100GB   ext4
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.