Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.04 64 Bit on a HP Pavilion dm4. It has a Broadcom 4313 Wireless Adapter and a Realtek RTL8168D/8111D Ethernet Adapter.

I haven't been able to get consistent internet access from either the wireless or wired connection. On startup, or after restarting the router, I am able to load a couple of websites, but after that the internet stops working (though the wirless/ethernet continue to indicate that they are connected). Strangely, I am still able to do things with the websites I have already loaded - for example, loading/sending messages in gmail. It's just loading certain new websites that is the issue. Also, I still see available wireless networks.

This the relevant output from lspci -v:

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
    Subsystem: Hewlett-Packard Company Device 1469
    Flags: bus master, fast devsel, latency 0, IRQ 42
    I/O ports at 2000 [size=256]
    Memory at c0404000 (64-bit, prefetchable) [size=4K]
    Memory at c0400000 (64-bit, prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: r8168
    Kernel modules: r8168

03:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
    Subsystem: Hewlett-Packard Company Device 145c
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at c2400000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: wl
    Kernel modules: wl, bcma, brcmsmac

I've tried blacklisting the different wireless drivers, but nothing seems to work, even if I try to force it to use the brcmsmac driver, which I've read elsewhere should be the correct one. For the ethernet, I also tried installing the latest driver (r8168 instead of r8169) and blacklisting the old one.

I'm dual booting windows 7 on the same laptop, but have no issues with either the wireless or ethernet connections.

share|improve this question
add comment

4 Answers

up vote 0 down vote accepted

Your problem apears to be with the network stack and not with the drivers.

Most problems I had were with name resolution try pinging a known site to check if name resolves ok.

share|improve this answer
    
with ethernet, pinging works briefly and then stops working while gmail continues to function. This time wireless didn't appear to work at all; it connected to the network but pinging returned nothing. –  eeyore42 Jun 14 '12 at 19:05
    
try running ifconfig to see if you are getting errors: RX packets:24699 errors:0 dropped:0 overruns:0 frame:0 TX packets:20649 errors:0 dropped:0 overruns:0 carrier:0 –  tneiva Jun 14 '12 at 19:18
    
not getting any errors. it does seem to be a dns problem... I'm wondering if it's related to this: bugs.launchpad.net/ubuntu/+source/network-manager/+bug/989900 –  eeyore42 Jun 14 '12 at 19:30
    
from that bug report page I got this link, read the part on dnsmasq: akyl.net/changes-dns-resolvconf-ubuntu-1204-precise-pangolin –  tneiva Jun 14 '12 at 19:43
1  
from that page, this is what solved it: "To turn off dnsmasq in Network Manager, you need to edit /etc/NetworkManager/NetworkManager.conf and comment the “dns=dnsmasq” line then do a “sudo restart network-manager”." –  eeyore42 Jun 14 '12 at 19:48
show 1 more comment

I had the same problem. After trying almost every possible solution posted in different wikis, I've figured it out in this way: try to set the channel of the wireless in your router under 12 (I've set on 11). The wl driver for broadcom 4313 works only under this channel. I hope it works for you too.

share|improve this answer
add comment

Did you try setting ipv6 to link-local only? My problem was almost identical to the one you described and after I did this, the difference is like night and day.

rtl8192ce driven RTL8188 Realtek wifi card

Broadcom driven wireless router

Ubuntu-Gnome 13.04

I ONLY run on n. (I paid for the latest technology and I want to use it.)

Again . . . IPV6 to Local-Link Only. Go to Network Manager and edit the profile of the network you are connected to and you will find a setting for IPV6.

My ISP does not even offer IPV6 so it took me a while to figure this out. Before, I tried to disable it thinking it was useless and not needed. I'll see how long my connection lasts, however, I was only receiving 2 out of 5 pings to my router before and now I get 5 out of 5 returned in full. Also, Google searches are lightning fast . . . no more clocking for 3-5 minutes. Hope this helps! Good Luck

share|improve this answer
add comment

Hooray I fixed it. Setting it IPV6 to Local-Link Only did the trick. It is odd though that everything was going fine until about 2 days ago.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.