Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install a program (valgrind) which needs libc6-dbg. On the other hand, I cannot install libc6-dbg because:

The following packages have unmet dependencies:
   libc6-dbg: Depends: libc6 (= 2.11.1-0ubuntu7) but 2.11.1-0ubuntu7.2 is to be installed
E: Broken packages

which means I have a newer version of libc6 installed. However:

sudo apt-get install libc6-dbg=2.11.1-0ubuntu7.2

doesn't find anything. I am guessing I need to add the PPA containing that package, which is where I ran out of luck.

I found the package I need here (my ubuntu is Lucid):, however, I can't seem to figure out what I should do to get apt-get to see and install this package.


share|improve this question
up vote 5 down vote accepted

-dbg packages provide debug symbols for programs and libraries provided by the packages that are named like them but without -dbg. (Sometimes they provide debug symbols for a whole group packages, typically whose names start like them without -dbg and then contain more text.)

In this case, you have libc6 installed (that's a core package without which no Ubuntu system can run), and you want to install libc6-dbg. This must correspond exactly to the installed version of libc6. Getting a separate version of libc6-dbg from a PPA that didn't correspond to the installed version of libc6 would be very bad--it would not be usable.

As this page indicates, on a Lucid system both libc6 and (if it is installed) libc6-dbg should be at version 2.11.1-0ubuntu7.10. So it looks like you have an old version of libc6 installed (which is possibly vulnerable to well-known security bugs!), for which libc6-dbg may no longer be available.

Not only do you have an old version of libc6, but your information about what the latest versions of libc6 and libc6-dbg is out of date. Try this to correct it:

sudo apt-get update

If you're installing packages on the command-line, you should always run that first (unless you've run it just recently).

Then run this to upgrade your system's packages (including libc6):

sudo apt-get upgrade

Then try again:

sudo apt-get install libc6-dbg

If that still doesn't work, check your Software Sources (by going to the Update Manager and clicking the Settings... button at the lower-left corner). Click on the Updates Tab. Make sure that Important security updates (lucid-security) and Recommended updates (lucid-updates) are enabled (checked).

Ubuntu 10.04 LTS, Software Sources window, Updates tab

That image is taken from these instructions, written by Contributors to the Ubuntu documentation wiki and licensed under CC-BY-SA 3.0. Content on Ask Ubuntu including this post is also licensed that way. Thus my incorporation of that image is permitted here.

Then after enabling those software sources, run these commands again:

sudo apt-get update
sudo apt-get upgrade

And then try again:

sudo apt-get install libc6-dbg
share|improve this answer
That was it. The guy who had installed this ubuntu had somehow disabled lucid-security and lucid-updates – Shahbaz Jun 14 '12 at 17:01

In general (answering your title question): for searching/adding ppa's you could use Y PPA Manager.

After adding you update your sources and install the package from source you want...

share|improve this answer
That's quite nice! I hope others who came for the real question in the title wouldn't miss your post – Shahbaz Jun 14 '12 at 22:55

You should update your system, for example with

 sudo apt-get update
 sudo apt-get upgrade

If that doesn't help make sure you have the security updates enabled.

The current version of libc6 in Lucid is 2.11.1-0ubuntu7.10, the corresponding libc6-dbg is available from the official software sources.

share|improve this answer
My synaptic says the latest version of libc6 is 2.11.1-0ubuntu7.2 and libc6-dbg is 2.11.1-0ubuntu7! I have already tried with apt-get update and upgrade on libc6 and libc6-dev (a total upgrade also says there are no packages for upgrade (my system is up-to-date)) – Shahbaz Jun 14 '12 at 16:55

It looks like 'libc6-dbg' is the package name, and '=2.11.1-0ubuntu7.2' is the version. Try using

sudo apt-get install libc6-dbg

Or use the synaptic package manager.

These two methods will install a newer version of libc6-dbg. If you have to have the older one, you can download the .deb file for it on the right side of the launchpad page you linked.

share|improve this answer
That was the first thing I tried. Since it didn't work, I tried with the specific version. Also, synaptic shows =2.11.1-0ubuntu7 as the latest version. That is why I am looking for a way (possibly by adding the right PPA) to let it get the newer version from a different repository. – Shahbaz Jun 14 '12 at 16:54

Maybe an update of libc6 and libc6-dbg would help? There are newer versions (with security updates) of both packages available:

I think 2.11.1-0ubuntu7 is not in the repositories anymore.

sudo apt-get update
sudo apt-get upgrade

should solve the problem.

share|improve this answer
I have tried update followed by upgrade libc6, and upgrade libc6-dev, but it didn't upgrade anything. The problem persists – Shahbaz Jun 14 '12 at 16:53

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.