Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My notebook is connected to a HDTV through a KVM Switch (one other notebook also connected to the same HDTV). The problem seems to be that Ubuntu doesn't recognize the HDTV to be turned on and therefore doesn't enable the VGA output. As far as I understand it has something to do with EDID information not being send trough the KVM Switch.

xrandr won't enable the VGA output through xrandr --output VGA1 --auto, it just keeps showing as disconnected.

Can I somehow force the VGA port to send a signal?

My Graphics Controller:

Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
share|improve this question

2 Answers 2

Yes,you can , but --auto is doing the right thing. Instead do something like:

xrandr --addmode VGA1 1024x768
xrandr --output VGA1 --mode 1024x768 --right-of LVDS1

For other users with a similar problem on all video outputs, first run xrandr to see what outputs you have.

~$ xrandr -q
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
eDP1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 294mm x 165mm
   1920x1080      60.0*+   59.9     40.0  
   1680x1050      60.0     59.9  
   1600x1024      60.2  
   1400x1050      60.0  
   1280x1024      60.0  
   1440x900       59.9  
   1280x960       60.0  
   1360x768       59.8     60.0  
   1152x864       60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
   1024x768       60.0  
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
   1024x768       60.0  

In this case the main screen is called eDP1 and the additional outputs are VGA1, HDMI1 and DP1 (Mini DisplayPort)

As an example, to force output to the Mini DisplayPort at 720x480 run

xrandr --addmode DP1 720x480

and then

xrandr --output DP1 --mode 720x480 --right-of eDP1
share|improve this answer
I managed to get output over displayport to VGA adapter this way. However, the screen does not update properly, only when I move a window. Also there are those ugly laggy overlays. Any idea how this may be solved? –  user1901493 Feb 11 at 11:02

I had problems with some VGA cables that has DDC (display data channel) broken or not connected. I found this useful workaround using boot parameter to force kernel to see a disconnected VGA: video={conn}:{res}e conn should match xrandr device name res 1024x768 (or what ever you prefer) e means to enable the port (even if no device/monitor is detected).

See: http://distro.ibiblio.org/fatdog/web/faqs/boot-options.html

share|improve this answer
This method looks interesting. " to force kernel to see a disconnected VGA: video={conn}:{res}e conn " Which parameters have you given to let the LCD + VGA (cloning) beeing run at boot? thanks –  user278661 May 6 '14 at 16:07
For {conn} use the VGA identifier (you can check performing a xrandr command) in my case "VGA-1". About {res}, you should use the resolution that you suppose the external monitor can support: usually the minimum 1024x768. –  dmarrazzo Jun 14 '14 at 7:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.