Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

(This is a continuation of thread: Installing nvidia driver?).

I am able to detect and configure an external monitor using nvidia-settings program. However, when I try to save my configuration, nvidia-settings complains that it can't save to xorg.conf.

It states that: "Default Device" must have a Driver line.

Now, I ran nvidia-settings using sudo, so this isn't a permissions problem. Here's my file (I am typing it by hand, since my ubuntu laptop has all sorts of config errors, created by my overconfident self. :)

Section "Device"
    Identifier    "Default Device"
    Option   "NoLogo"   "True"
EndSection

Do I just add a driver line? And what should it look like?

thanks.

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

Run nvidia-settings as root

gksu nvidia-settings

You can then save your setting.

When saving, unselect the "Merge with existing file" box

enter image description here

share|improve this answer
    
Thanks for the prompt response. Anyways, from the main window, I highlight the 'X Server Display Configuration', then on the right pane I press 'Save to X Configuration File'. After doing so, a box pops up stating that it can't be done. The erroe message is 'Failed to parse existing X config file '/etc/X11/xorg.conf'!'. I did use the exact command that you suggested, gksu nvidia-settings. Anyways, after clicking 'OK' on the pop up error window, I get the screen shot that you have displayed, without the graphics on save and cancel. However, the merge option is faded. What to do? thx –  Badministrator Jun 15 '12 at 20:07
add comment

The Driver line should look like this:

Driver         "nvidia"

You can just put it right under the identifier. For others with this issue, the xorg.conf file is located at /etc/X11/xorg.conf I think you will need to reboot after making this change.

share|improve this answer
    
Thanks. I was able to get beyond my initial problem. Now, when I reboot, I see that I can use my external monitor along with my laptop display. However, when I login, I get an error box that pops up: Could not apply the stored configuration for monitors. Under that, is more details: none of the selected modes were compatible with the possible modes: Trying modes for CRTC 351. CRTC 351: trying mode 3360x1080@50HZ with output at 1440x900@50Hz (pass 0) There is an identical message with (pass 1). But, everything seems to work. Any suggestions? I'll play with the configs. –  Badministrator Jun 15 '12 at 20:36
    
Oh, one weird thing, my external monitor does not have 3360x1080 resolution. I don't know where it got that. My resolution is 1920x1080 for the external monitor. –  Badministrator Jun 15 '12 at 20:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.