Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I was given the option to Upgrade to Ubuntu 12.10 I did try to Upgrade, but while it was upgrading the internet connection was lost and the system went through a partial upgrade. Now when I try to open the Update Manager or the Software Sources it opens and crashes automatically.

What should I do?

share|improve this question
this may help you… – virpara Jun 14 '12 at 13:04
and – virpara Jun 14 '12 at 13:13
have you tried the command: (in a terminal) sudo dpkg --configure -a as stated here ? – Alvar Jun 14 '12 at 13:17
What do you do after the partial upgrade (my current situation) – Joel Jun 14 '12 at 13:21
you try to complete the upgrade so you get a working 12.04. It's always better to make a fresh install when something like this happens, with a fresh install you wont get any errors or slow performance. My 11.10 broke and now it takes 3 minutes to boot up. – Alvar Jun 14 '12 at 13:32

When package upgrades are interrupted in midway, normally doing sudo dpkg --configure -a && sudo apt-get -f install && sudo apt-get upgrade will save the situation, but when is a full release upgrade (jumping from a version to another) the steps becomes more tricky.

What's the best solution for this cases? Reinstall. If you are not capable to reinstall, you may want to continue the upgrade using sudo update-manager-text or sudo apt-get dist-upgrade (the last one you shall modify your sources.list from oneiric to precise, see my command at the end), but that I won't guarantee will work. Other option is sudo do-releases-upgrade, but you must make sure that the process is not interrupted this time around.

To use apt-get dist-upgrade

sudo sed s/oneiric/precise/g /etc/apt/sources.list
sudo apt-get update
sudo apt-get dist-upgrade
share|improve this answer
apt-get dist-upgrade won't try to upgrade to the next release unless you manually edit /etc/apt/sources.list first (and run apt-get update). apt-get dist-upgrade is a perfectly good command to run to install updates for the currently installed Ubuntu release including those that require new packages to be installed or currently installed packages to be removed (that's the difference between it and apt-get upgrade). It is, to a significant extent, a historical curiosity that it's called dist-upgrade; as you say, on Ubuntu it should not be used to do a release upgrade. – Eliah Kagan Aug 16 '13 at 13:54
@EliahKagan I'm basing my answers in this official guide that specifically says, that do-release-upgrade is recommended than sudo apt-get dist-upgrade. I've used do-release-upgrade with ease in the past for servers upgrades (although I reckon that not desktop) but reading more into it, seems that the update-manager do the same that apt-get dist-upgrade so it may worth a shot. Also, I had this problem once (not crashing but the upgrade simply don't go) when long history short I had to reinstall, which is not the... – Braiam Aug 16 '13 at 15:54
solution OP wants/could do. I could add the use of update-manager-text and apt-get dist-upgrade as alternative, but I don't have any experience that those solves midway upgrades. – Braiam Aug 16 '13 at 15:56
I'm not disagreeing with using do-release-upgrade in this situation (provided that the goal is to upgrade from one release to another). You are totally right that do-release-upgrade is the correct way to upgrade from an earlier Ubuntu release to a later release, from the command-line. (Not for anything else, though.) The only point I'm making here is that apt-get dist-upgrade is perfectly appropriate for many uses (uses other than upgrading to a new release), and that since running it doesn't attempt an upgrade without an edit to sources.list, it's generally quite safe to run. – Eliah Kagan Aug 16 '13 at 15:58

Experienced a similar problem with my old laptop. I tried most of the suggestions above but kept coming with the same "partial upgrade" problem which when you run it fails giving other permissions/upgrade errors.

After many attempts I decided to give synaptic package manager a try. I chose the option for custom filters - then the option for "marked changes" and found one linux header marked as upgradable. Immediately upgraded the package which went smoothly. Then reloaded synaptic again and went down the same options in custom filters - this time I chose the option "upgradable(upstream). Found more packages that had failed in the upgrade and upgraded those. Reloaded synaptic once more and this time around synaptic found fewer packages that needed upgrading. After upgrading the last few packages I rebooted and everything went on smooth from there. Hope this helps someone.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.